{"answers":{"affected":"2 open source packages ship an affected version, including next. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23646 in the wild and no public exploit code.","fix":"Upgrade next to 12.1.0 or later.","what":"CVE-2022-23646 is a medium-severity cross-site scripting vulnerability in Vercel Next.js, published on 17 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23646 and fix it if it is affected.\n\nWhat it is: CVE-2022-23646 is a medium-severity cross-site scripting vulnerability in Vercel Next.js, published on 17 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23646 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- next (npm): affected from 10.0.0; fixed in 12.1.0\n- next (npm): affected from 10.0.0; fixed in 12.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23646/ (Markdown: https://insights.sbomify.com/CVE-2022-23646/index.md)","id":"CVE-2022-23646","markdown":"https://insights.sbomify.com/CVE-2022-23646/index.md","name":"CVE-2022-23646","record":{"aliases":["GHSA-fmvm-x8mv-47mj","ROOT-APP-NPM-CVE-2022-23646"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Next.js framework","requires_auth":"none","summary":"Attackers can exploit improper CSP in Next.js Image Optimization API to perform UI misrepresentation via SVGs if specific image domains are configured.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"next.js","vendor":"vercel"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-451","name":"User Interface (UI) Misrepresentation of Critical Information"}],"description":"Next.js is a React framework. Starting with version 10.0.0 and prior to version 12.1.0, Next.js is vulnerable to User Interface (UI) Misrepresentation of Critical Information. In order to be affected, the `next.config.js` file must have an `images.domains` array assigned and the image host assigned in `images.domains` must allow user-provided SVG. If the `next.config.js` file has `images.loader` assigned to something other than default, the instance is not affected. Version 12.1.0 contains a patch for this issue. As a workaround, change `next.config.js` to use a different `loader configuration` other than the default.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper CSP in Image Optimization API for Next.js","id":"CVE-2022-23646","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"vercel:next.js","products":["vercel:next.js"],"type":"xss","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site Scripting in Prism","id":"CVE-2022-23647"},"packages":[{"ecosystem":"npm","fixed":["12.1.0"],"introduced":["10.0.0"],"last_affected":[],"package":"next","purl":null,"source":"GHSA-fmvm-x8mv-47mj"},{"ecosystem":"npm","fixed":["12.1.0"],"introduced":["10.0.0"],"last_affected":[],"package":"next","purl":"pkg:npm/next","source":"GHSA-fmvm-x8mv-47mj"}],"prev":{"headline":"Out-of-bounds read in swtpm","id":"CVE-2022-23645"},"products":["next.js"],"published":"2022-02-17","related":[{"cvss_score":9.1,"headline":"Authorization Bypass in Next.js Middleware","id":"CVE-2025-29927","kev_date_added":null,"published":"2025-03-21"},{"cvss_score":8.6,"headline":"Next.js: Server-side request forgery in applications using WebSocket upgrades","id":"CVE-2026-44578","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":8.3,"headline":"Next.js: Server-Side Request Forgery in Image Optimization","id":"CVE-2026-94483","kev_date_added":null,"published":"2026-10-02"},{"cvss_score":8.3,"headline":"Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale","id":"CVE-2026-64642","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":8.3,"headline":"Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname","id":"CVE-2026-64645","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":8.3,"headline":"Next.js: Server-Side Request Forgery in Server Actions on Custom Servers","id":"CVE-2026-64649","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":8.2,"headline":"Next.js: Denial of Service in App Router using Server Actions","id":"CVE-2026-64641","kev_date_added":null,"published":"2026-07-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["vercel"]},"summary":"Attackers can exploit improper CSP in Next.js Image Optimization API to perform UI misrepresentation via SVGs if specific image domains are configured.","url":"https://insights.sbomify.com/CVE-2022-23646/"}