# CVE-2022-23646: Improper CSP in Image Optimization API for Next.js

> Attackers can exploit improper CSP in Next.js Image Optimization API to perform UI misrepresentation via SVGs if specific image domains are configured.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-fmvm-x8mv-47mj, ROOT-APP-NPM-CVE-2022-23646

## What is CVE-2022-23646?

CVE-2022-23646 is a medium-severity cross-site scripting vulnerability in Vercel Next.js, published on 17 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework. Starting with version 10.0.0 and prior to version 12.1.0, Next.js is vulnerable to User Interface (UI) Misrepresentation of Critical Information. In order to be affected, the `next.config.js` file must have an `images.domains` array assigned and the image host assigned in `images.domains` must allow user-provided SVG. If the `next.config.js` file has `images.loader` assigned to something other than default, the instance is not affected. Version 12.1.0 contains a patch for this issue. As a workaround, change `next.config.js` to use a different `loader configuration` other than the default.

Weakness: CWE-451 (User Interface (UI) Misrepresentation of Critical Information)

## Which versions are affected by CVE-2022-23646?

2 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 10.0.0 | 12.1.0 |
| `next` | npm | From 10.0.0 | 12.1.0 |

Products: Vercel Next.js.

## How do I fix CVE-2022-23646?

Upgrade next to 12.1.0 or later.

## Is CVE-2022-23646 being exploited?

There is no known exploitation of CVE-2022-23646 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23646 and fix it if it is affected.

What it is: CVE-2022-23646 is a medium-severity cross-site scripting vulnerability in Vercel Next.js, published on 17 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23646 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 10.0.0; fixed in 12.1.0
- next (npm): affected from 10.0.0; fixed in 12.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23646/ (Markdown: https://insights.sbomify.com/CVE-2022-23646/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23646
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23646
- OSV: https://osv.dev/vulnerability/CVE-2022-23646

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23646/
Summaries are generated and may contain mistakes; the official description above is the record.
