CVE-2022-23647 Cross-site Scripting in Prism

High 7.5 Published Updated

Attackers can execute arbitrary JavaScript via the command line plugin in Prism due to improper output escaping, affecting websites using this specific plugin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-23647?

CVE-2022-23647 is a high-severity cross-site scripting vulnerability in PrismJS prism, published on 18 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Prism is a syntax highlighting library. Starting with version 1.14.0 and prior to version 1.27.0, Prism's command line plugin can be used by attackers to achieve a cross-site scripting attack. The command line plugin did not properly escape its output, leading to the input text being inserted into the DOM as HTML code. Server-side usage of Prism is not impacted. Websites that do not use the Command Line plugin are also not impacted. This bug has been fixed in v1.27.0. As a workaround, do not use the command line plugin on untrusted inputs, or sanitize all code blocks (remove all HTML code text) from all code blocks that use the command line plugin.

Weakness: CWE-79

Which versions are affected by CVE-2022-23647?

2 open source packages ship an affected version, including prismjs. It affects 1 product.

PackageAffectedFixed in
prismjs npmFrom 1.14.01.27.0
prismjs npmFrom 1.14.01.27.0

Products include Prismjs Prism.

How do I fix CVE-2022-23647?

Upgrade prismjs to 1.27.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-23647 being exploited?

There is no known exploitation of CVE-2022-23647 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2022-23647, GHSA-3949-f494-cm99, ROOT-APP-NPM-CVE-2022-23647, UBUNTU-CVE-2022-23647.

Is CVE-2022-23647 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free