{"answers":{"affected":"2 open source packages ship an affected version, including prismjs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23647 in the wild and no public exploit code.","fix":"Upgrade prismjs to 1.27.0 or later.","what":"CVE-2022-23647 is a high-severity cross-site scripting vulnerability in PrismJS prism, published on 18 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-23647 and fix it if it is affected.\n\nWhat it is: CVE-2022-23647 is a high-severity cross-site scripting vulnerability in PrismJS prism, published on 18 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-23647 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prismjs (npm): affected from 1.14.0; fixed in 1.27.0\n- prismjs (npm): affected from 1.14.0; fixed in 1.27.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23647/ (Markdown: https://insights.sbomify.com/CVE-2022-23647/index.md)","id":"CVE-2022-23647","markdown":"https://insights.sbomify.com/CVE-2022-23647/index.md","name":"CVE-2022-23647","record":{"aliases":["DEBIAN-CVE-2022-23647","GHSA-3949-f494-cm99","ROOT-APP-NPM-CVE-2022-23647","UBUNTU-CVE-2022-23647"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript syntax highlighting library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via the command line plugin in Prism due to improper output escaping, affecting websites using this specific plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"prism","vendor":"prismjs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Prism is a syntax highlighting library. Starting with version 1.14.0 and prior to version 1.27.0, Prism's command line plugin can be used by attackers to achieve a cross-site scripting attack. The command line plugin did not properly escape its output, leading to the input text being inserted into the DOM as HTML code. Server-side usage of Prism is not impacted. Websites that do not use the Command Line plugin are also not impacted. This bug has been fixed in v1.27.0. As a workaround, do not use the command line plugin on untrusted inputs, or sanitize all code blocks (remove all HTML code text) from all code blocks that use the command line plugin.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in Prism","id":"CVE-2022-23647","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Insecure handling of image volumes in containerd CRI plugin","id":"CVE-2022-23648"},"packages":[{"ecosystem":"npm","fixed":["1.27.0"],"introduced":["1.14.0"],"last_affected":[],"package":"prismjs","purl":null,"source":"GHSA-3949-f494-cm99"},{"ecosystem":"npm","fixed":["1.27.0"],"introduced":["1.14.0"],"last_affected":[],"package":"prismjs","purl":"pkg:npm/prismjs","source":"GHSA-3949-f494-cm99"}],"prev":{"headline":"Improper CSP in Image Optimization API for Next.js","id":"CVE-2022-23646"},"products":["prism"],"published":"2022-02-18","related":[{"cvss_score":7.5,"headline":"Inefficient Regular Expression Complexity in prismjs/prism","id":"CVE-2021-3801","kev_date_added":null,"published":"2021-09-15"},{"cvss_score":7.5,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23341","kev_date_added":null,"published":"2021-02-18"},{"cvss_score":4.9,"headline":"PrismJS DOM Clobbering vulnerability","id":"CVE-2024-53382","kev_date_added":null,"published":"2025-03-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["PrismJS"]},"summary":"Attackers can execute arbitrary JavaScript via the command line plugin in Prism due to improper output escaping, affecting websites using this specific plugin.","url":"https://insights.sbomify.com/CVE-2022-23647/"}