# CVE-2022-23647: Cross-site Scripting in Prism

> Attackers can execute arbitrary JavaScript via the command line plugin in Prism due to improper output escaping, affecting websites using this specific plugin.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-23647, GHSA-3949-f494-cm99, ROOT-APP-NPM-CVE-2022-23647, UBUNTU-CVE-2022-23647

## What is CVE-2022-23647?

CVE-2022-23647 is a high-severity cross-site scripting vulnerability in PrismJS prism, published on 18 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Prism is a syntax highlighting library. Starting with version 1.14.0 and prior to version 1.27.0, Prism's command line plugin can be used by attackers to achieve a cross-site scripting attack. The command line plugin did not properly escape its output, leading to the input text being inserted into the DOM as HTML code. Server-side usage of Prism is not impacted. Websites that do not use the Command Line plugin are also not impacted. This bug has been fixed in v1.27.0. As a workaround, do not use the command line plugin on untrusted inputs, or sanitize all code blocks (remove all HTML code text) from all code blocks that use the command line plugin.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-23647?

2 open source packages ship an affected version, including prismjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prismjs` | npm | From 1.14.0 | 1.27.0 |
| `prismjs` | npm | From 1.14.0 | 1.27.0 |

Products: Prismjs Prism.

## How do I fix CVE-2022-23647?

Upgrade prismjs to 1.27.0 or later.

## Is CVE-2022-23647 being exploited?

There is no known exploitation of CVE-2022-23647 in the wild and no public exploit code.

## Other vulnerabilities in PrismJS prism

- [CVE-2021-3801](https://insights.sbomify.com/CVE-2021-3801/): Inefficient Regular Expression Complexity in prismjs/prism (high 7.5)
- [CVE-2021-23341](https://insights.sbomify.com/CVE-2021-23341/): Regular Expression Denial of Service (ReDoS) (high 7.5)
- [CVE-2024-53382](https://insights.sbomify.com/CVE-2024-53382/): PrismJS DOM Clobbering vulnerability (medium 4.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23647 and fix it if it is affected.

What it is: CVE-2022-23647 is a high-severity cross-site scripting vulnerability in PrismJS prism, published on 18 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23647 in the wild and no public exploit code.

Affected packages and fixed versions:
- prismjs (npm): affected from 1.14.0; fixed in 1.27.0
- prismjs (npm): affected from 1.14.0; fixed in 1.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23647/ (Markdown: https://insights.sbomify.com/CVE-2022-23647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23647
- OSV: https://osv.dev/vulnerability/CVE-2022-23647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23647/
Summaries are generated and may contain mistakes; the official description above is the record.
