# CVE-2022-23648: Insecure handling of image volumes in containerd CRI plugin

> Attackers can read arbitrary host files via crafted container images, bypassing security policies and exposing sensitive data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** CLEANSTART-2025-XK69277, DEBIAN-CVE-2022-23648, DSA-5091-1, GHSA-crp2-qrr5-8pq7, GO-2022-0344, MGASA-2022-0088, OESA-2022-1671, SUSE-SU-2022:0719-1, SUSE-SU-2022:0720-1, SUSE-SU-2022:0720-2, UBUNTU-CVE-2022-23648, USN-5311-1, USN-5311-2, openSUSE-SU-2022:0720-1, openSUSE-SU-2024:11891-1, openSUSE-SU-2024:12008-1

## What is CVE-2022-23648?

CVE-2022-23648 is a high-severity vulnerability in Debian Debian Linux, published on 3 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

containerd is a container runtime available as a daemon for Linux and Windows. A bug was found in containerd prior to versions 1.6.1, 1.5.10, and 1.14.12 where containers launched through containerd’s CRI implementation on Linux with a specially-crafted image configuration could gain access to read-only copies of arbitrary files and directories on the host. This may bypass any policy-based enforcement on container setup (including a Kubernetes Pod Security Policy) and expose potentially sensitive information. Kubernetes and crictl can both be configured to use containerd’s CRI implementation. This bug has been fixed in containerd 1.6.1, 1.5.10, and 1.4.12. Users should update to these versions to resolve the issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-23648?

7 open source packages ship an affected version, including github.com/containerd/containerd. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containerd/containerd` | Go | All versions | 1.4.13, 1.5.10, 1.6.1 |
| `github.com/containerd/containerd` | Go | All versions | 1.4.13 |
| `github.com/containerd/containerd` | Go | All versions | 1.4.13 |
| `github.com/containerd/containerd` | Go | From 1.5.0 | 1.5.10 |
| `github.com/containerd/containerd` | Go | From 1.5.0 | 1.5.10 |
| `github.com/containerd/containerd` | Go | From 1.6.0 | 1.6.1 |
| `github.com/containerd/containerd` | Go | From 1.6.0 | 1.6.1 |
| `containerd` | SUSE:Linux Enterprise Micro 5.0 | All versions | 1.4.12-63.1 |
| `containerd` | SUSE:Linux Enterprise Micro 5.1 | All versions | 1.4.12-63.1 |
| `containerd` | SUSE:Linux Enterprise Micro 5.2 | All versions | 1.4.12-63.1 |
| `containerd` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 1.4.13-16.54.1 |
| `containerd` | SUSE:Linux Enterprise Module for Containers 15 SP3 | All versions | 1.4.12-63.1 |
| `containerd` | openSUSE:Leap 15.3 | All versions | 1.4.12-63.1 |
| `containerd` | openSUSE:Tumbleweed | All versions | 1.4.13-1.1 |
| `trivy` | openSUSE:Tumbleweed | All versions | 0.26.0-1.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Linuxfoundation Containerd.

## How do I fix CVE-2022-23648?

Upgrade github.com/containerd/containerd to a fixed version for your release line: 1.4.13, 1.5.10 or 1.6.1.

## Is CVE-2022-23648 being exploited?

There is no known exploitation of CVE-2022-23648 in the wild and no public exploit code.

Public exploit code:

- POC for CVE-2022-23648 (github_poc): https://github.com/raesene/CVE-2022-23648-POC

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23648 and fix it if it is affected.

What it is: CVE-2022-23648 is a high-severity vulnerability in Debian Debian Linux, published on 3 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23648 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.4.13, 1.5.10, 1.6.1
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.4.13
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.4.13
- github.com/containerd/containerd (Go): affected from 1.5.0; fixed in 1.5.10
- github.com/containerd/containerd (Go): affected from 1.5.0; fixed in 1.5.10
- github.com/containerd/containerd (Go): affected from 1.6.0; fixed in 1.6.1
- github.com/containerd/containerd (Go): affected from 1.6.0; fixed in 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23648/ (Markdown: https://insights.sbomify.com/CVE-2022-23648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23648
- OSV: https://osv.dev/vulnerability/CVE-2022-23648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23648/
Summaries are generated and may contain mistakes; the official description above is the record.
