# CVE-2022-23649: Improper Certificate Validation in Cosign

> Attackers with OCI permissions can bypass Rekor transparency log verification, falsely claiming signatures are logged when they are not.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-cosign-2022-23649, CLEANSTART-2026-QF47090, GHSA-ccxc-vr6p-4858, GO-2022-0326, openSUSE-SU-2024:11860-1

## What is CVE-2022-23649?

CVE-2022-23649 is a low-severity vulnerability in sigstore cosign, published on 18 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cosign provides container signing, verification, and storage in an OCI registry for the sigstore project. Prior to version 1.5.2, Cosign can be manipulated to claim that an entry for a signature exists in the Rekor transparency log even if it doesn't. This requires the attacker to have pull and push permissions for the signature in OCI. This can happen with both standard signing with a keypair and "keyless signing" with Fulcio. If an attacker has access to the signature in OCI, they can manipulate cosign into believing the entry was stored in Rekor even though it wasn't. The vulnerability has been patched in v1.5.2 of Cosign. The `signature` in the `signedEntryTimestamp` provided by Rekor is now compared to the `signature` that is being verified. If these don't match, then an error is returned. If a valid bundle is copied to a different signature, verification should fail. Cosign output now only informs the user that certificates were verified if a certificate was in fact verified. There is currently no known workaround.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2022-23649?

4 open source packages ship an affected version, including github.com/sigstore/cosign and cosign. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/sigstore/cosign` | Go | All versions | 1.5.2 |
| `github.com/sigstore/cosign` | Go | All versions | 1.5.2 |
| `github.com/sigstore/cosign` | Go | All versions | 1.5.2 |
| `cosign` | Bitnami | All versions | 1.5.2 |
| `cosign` | openSUSE:Tumbleweed | All versions | 1.5.2-1.1 |

Products: Sigstore Cosign.

## How do I fix CVE-2022-23649?

Upgrade github.com/sigstore/cosign to 1.5.2 or later.

## Is CVE-2022-23649 being exploited?

There is no known exploitation of CVE-2022-23649 in the wild and no public exploit code.

## Other vulnerabilities in sigstore cosign

- [CVE-2022-35929](https://insights.sbomify.com/CVE-2022-35929/): False positive signature verification in cosign (high 7.1)
- [CVE-2026-22703](https://insights.sbomify.com/CVE-2026-22703/): Cosign verification accepts any valid Rekor entry under certain conditions (medium 5.5)
- [CVE-2022-36056](https://insights.sbomify.com/CVE-2022-36056/): Vulnerabilities with blob verification in sigstore cosign (medium 5.5)
- [CVE-2026-39395](https://insights.sbomify.com/CVE-2026-39395/): Cosign's verify-blob-attestation reports false positive when payload parsing fails (medium 4.3)
- [CVE-2024-29902](https://insights.sbomify.com/CVE-2024-29902/): Cosign vulnerable to system-wide denial of service via malicious attachments (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23649 and fix it if it is affected.

What it is: CVE-2022-23649 is a low-severity vulnerability in sigstore cosign, published on 18 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23649 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/sigstore/cosign (Go): affected all versions; fixed in 1.5.2
- github.com/sigstore/cosign (Go): affected all versions; fixed in 1.5.2
- github.com/sigstore/cosign (Go): affected all versions; fixed in 1.5.2
- cosign (Bitnami): affected all versions; fixed in 1.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23649/ (Markdown: https://insights.sbomify.com/CVE-2022-23649/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23649
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23649
- OSV: https://osv.dev/vulnerability/CVE-2022-23649

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23649/
Summaries are generated and may contain mistakes; the official description above is the record.
