# CVE-2022-23650: Use of Hard-coded Cryptographic Key in Netmaker

> Attackers can execute admin commands on remote Netmaker servers using a hard-coded cryptographic key, requiring knowledge of the admin address and username.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-86f3-hf24-76q4, GO-2022-0328

## What is CVE-2022-23650?

CVE-2022-23650 is a high-severity vulnerability in gravitl netmaker, published on 18 Feb 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Netmaker is a platform for creating and managing virtual overlay networks using WireGuard. Prior to versions 0.8.5, 0.9.4, and 010.0, there is a hard-coded cryptographic key in the code base which can be exploited to run admin commands on a remote server if the exploiter know the address and username of the admin. This effects the server (netmaker) component, and not clients. This has been patched in Netmaker v0.8.5, v0.9.4, and v0.10.0. There are currently no known workarounds.

Weakness: CWE-798 (Use of Hard-coded Credentials), CWE-321 (Use of Hard-coded Cryptographic Key)

## Which versions are affected by CVE-2022-23650?

5 open source packages ship an affected version, including github.com/gravitl/netmaker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gravitl/netmaker` | Go | All versions | 0.8.5, 0.9.4 |
| `github.com/gravitl/netmaker` | Go | All versions | 0.8.5 |
| `github.com/gravitl/netmaker` | Go | All versions | 0.8.5 |
| `github.com/gravitl/netmaker` | Go | From 0.9.0 | 0.9.4 |
| `github.com/gravitl/netmaker` | Go | From 0.9.0 | 0.9.4 |

Products: Netmaker Netmaker.

## How do I fix CVE-2022-23650?

Upgrade github.com/gravitl/netmaker to a fixed version for your release line: 0.8.5 or 0.9.4.

## Is CVE-2022-23650 being exploited?

There is no known exploitation of CVE-2022-23650 in the wild and no public exploit code.

## Other vulnerabilities in gravitl netmaker

- [CVE-2023-32079](https://insights.sbomify.com/CVE-2023-32079/): Netmaker Privilige Escalation Vulnerability (high 8.8)
- [CVE-2022-36110](https://insights.sbomify.com/CVE-2022-36110/): Netmaker vulnerable to Insufficient Granularity of Access Control (high 8.8)
- [CVE-2022-0664](https://insights.sbomify.com/CVE-2022-0664/): Use of Hard-coded Cryptographic Key in gravitl/netmaker (high 8.8)
- [CVE-2026-29771](https://insights.sbomify.com/CVE-2026-29771/): Netmaker: Denial of Service via Server Shutdown Endpoint (high 8.7)
- [CVE-2026-38651](https://insights.sbomify.com/CVE-2026-38651/): Netmaker does not verify JWT signatures for host tokens (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23650 and fix it if it is affected.

What it is: CVE-2022-23650 is a high-severity vulnerability in gravitl netmaker, published on 18 Feb 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23650 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/gravitl/netmaker (Go): affected all versions; fixed in 0.8.5, 0.9.4
- github.com/gravitl/netmaker (Go): affected all versions; fixed in 0.8.5
- github.com/gravitl/netmaker (Go): affected all versions; fixed in 0.8.5
- github.com/gravitl/netmaker (Go): affected from 0.9.0; fixed in 0.9.4
- github.com/gravitl/netmaker (Go): affected from 0.9.0; fixed in 0.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23650/ (Markdown: https://insights.sbomify.com/CVE-2022-23650/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23650
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23650
- OSV: https://osv.dev/vulnerability/CVE-2022-23650

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23650/
Summaries are generated and may contain mistakes; the official description above is the record.
