# CVE-2022-23652: Privilege escalation using hop-by-hop Connection header

> An authenticated attacker can escalate privileges to cluster-admin via a malicious Connection header in capsule-proxy.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Feb 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-9cwv-cppx-mqjm, GO-2022-0329

## What is CVE-2022-23652?

CVE-2022-23652 is a high-severity vulnerability in clastix capsule-proxy, published on 22 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

capsule-proxy is a reverse proxy for Capsule Operator which provides multi-tenancy in Kubernetes. In versions prior to 0.2.1 an attacker with a proper authentication mechanism may use a malicious `Connection` header to start a privilege escalation attack towards the Kubernetes API Server. This vulnerability allows for an exploit of the `cluster-admin` Role bound to `capsule-proxy`. There are no known workarounds for this issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-23652?

3 open source packages ship an affected version, including github.com/clastix/capsule-proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/clastix/capsule-proxy` | Go | All versions | 0.2.1 |
| `github.com/clastix/capsule-proxy` | Go | All versions | 0.2.1 |
| `github.com/clastix/capsule-proxy` | Go | All versions | 0.2.1 |

Products: Clastix Capsule-Proxy.

## How do I fix CVE-2022-23652?

Upgrade github.com/clastix/capsule-proxy to 0.2.1 or later.

## Is CVE-2022-23652 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23652 exists.

## Other vulnerabilities in clastix capsule-proxy

- [CVE-2023-48312](https://insights.sbomify.com/CVE-2023-48312/): Authentication bypass using an empty token in capsule-proxy (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23652 and fix it if it is affected.

What it is: CVE-2022-23652 is a high-severity vulnerability in clastix capsule-proxy, published on 22 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23652 exists.

Affected packages and fixed versions:
- github.com/clastix/capsule-proxy (Go): affected all versions; fixed in 0.2.1
- github.com/clastix/capsule-proxy (Go): affected all versions; fixed in 0.2.1
- github.com/clastix/capsule-proxy (Go): affected all versions; fixed in 0.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23652/ (Markdown: https://insights.sbomify.com/CVE-2022-23652/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23652
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23652
- OSV: https://osv.dev/vulnerability/CVE-2022-23652

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23652/
Summaries are generated and may contain mistakes; the official description above is the record.
