# CVE-2022-23653: B2 Command Line Tool TOCTOU application key disclosure

> Local attackers can exploit a race condition to read sensitive API keys from the B2 CLI configuration file during creation.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-8wr4-2wm6-w3pr, PYSEC-2022-32

## What is CVE-2022-23653?

CVE-2022-23653 is a medium-severity vulnerability in Backblaze B2_Command_Line_Tool, published on 23 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

B2 Command Line Tool is the official command line tool for the backblaze cloud storage service. Linux and Mac releases of the B2 command-line tool version 3.2.0 and below contain a key disclosure vulnerability that, in certain conditions, can be exploited by local attackers through a time-of-check-time-of-use (TOCTOU) race condition. The command line tool saves API keys (and bucket name-to-id mapping) in a local database file (`$XDG_CONFIG_HOME/b2/account_info`, `~/.b2_account_info` or a user-defined path) when `b2 authorize-account` is first run. This happens regardless of whether a valid key is provided or not. When first created, the file is world readable and is (typically a few milliseconds) later altered to be private to the user. If the directory is readable by a local attacker and the user did not yet run `b2 authorize-account` then during the brief period between file creation and permission modification, a local attacker can race to open the file and maintain a handle to it. This allows the local attacker to read the contents after the file after the sensitive information has been saved to it. Users that have not yet run `b2 authorize-account` should upgrade to B2 Command-Line Tool v3.2.1 before running it. Users that have run `b2 authorize-account` are safe if at the time of the file creation no other local users had read access to the local configuration file. Users that have run `b2 authorize-account` where the designated path could be opened by another local user should upgrade to B2 Command-Line Tool v3.2.1 and remove the database and regenerate all application keys. Note that `b2 clear-account` does not remove the database file and it should not be used to ensure that all open handles to the file are invalidated. If B2 Command-Line Tool cannot be upgraded to v3.2.1 due to a dependency conflict, a binary release can be used instead. Alternatively a new version could be installed within a virtualenv, or the permissions can be changed to prevent local users from opening the database file.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2022-23653?

3 open source packages ship an affected version, including b2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `b2` | PyPI | All versions | 3.2.1 |
| `b2` | PyPI | All versions | 3.2.1 |
| `b2` | PyPI | All versions | 3.2.1 |

Products: Backblaze B2 Command Line Tool.

## How do I fix CVE-2022-23653?

Upgrade b2 to 3.2.1 or later.

## Is CVE-2022-23653 being exploited?

There is no known exploitation of CVE-2022-23653 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23653 and fix it if it is affected.

What it is: CVE-2022-23653 is a medium-severity vulnerability in Backblaze B2_Command_Line_Tool, published on 23 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23653 in the wild and no public exploit code.

Affected packages and fixed versions:
- b2 (PyPI): affected all versions; fixed in 3.2.1
- b2 (PyPI): affected all versions; fixed in 3.2.1
- b2 (PyPI): affected all versions; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23653/ (Markdown: https://insights.sbomify.com/CVE-2022-23653/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23653
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23653
- OSV: https://osv.dev/vulnerability/CVE-2022-23653

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23653/
Summaries are generated and may contain mistakes; the official description above is the record.
