CVE-2022-2366 Incorrect defaults can cause attackers to bypass rate limitations
Attackers can bypass rate limits and manipulate audit logs by exploiting incorrect default trusted IP header settings in Mattermost.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-2366?
CVE-2022-2366 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 11 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Incorrect default configuration for trusted IP header in Mattermost version 6.7.0 and earlier allows attacker to bypass some of the rate limitations in place or use manipulated IPs for audit logging via manipulating the request headers.
Weakness: CWE-276
Which versions are affected by CVE-2022-2366?
1 open source package ship an affected version, including mattermost. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mattermost Bitnami | All versions to 6.7.0 | 6.3.9, 6.5.2, 6.6.2 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2022-2366?
Upgrade mattermost to a fixed version for your release line: 6.3.9, 6.5.2 or 6.6.2.
Is CVE-2022-2366 being exploited?
There is no known exploitation of CVE-2022-2366 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2022-2366, GHSA-8xxp-2g7w-ph6m.