{"answers":{"affected":"1 open source package ship an affected version, including mattermost. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-2366 in the wild and no public exploit code.","fix":"Upgrade mattermost to a fixed version for your release line: 6.3.9, 6.5.2 or 6.6.2.","what":"CVE-2022-2366 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 11 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-2366 and fix it if it is affected.\n\nWhat it is: CVE-2022-2366 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 11 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-2366 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mattermost (Bitnami): affected all versions up to 6.7.0; fixed in 6.3.9, 6.5.2, 6.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2366/ (Markdown: https://insights.sbomify.com/CVE-2022-2366/index.md)","id":"CVE-2022-2366","markdown":"https://insights.sbomify.com/CVE-2022-2366/index.md","name":"CVE-2022-2366","record":{"aliases":["BIT-mattermost-2022-2366","GHSA-8xxp-2g7w-ph6m"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["security_bypass","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Mattermost chat platform","requires_auth":"none","summary":"Attackers can bypass rate limits and manipulate audit logs by exploiting incorrect default trusted IP header settings in Mattermost.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mattermost","cpe":[{"product":"mattermost_server","vendor":"mattermost"}],"cvss":{"score":5.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"Incorrect default configuration for trusted IP header in Mattermost version 6.7.0 and earlier allows attacker to bypass some of the rate limitations in place or use manipulated IPs for audit logging via manipulating the request headers.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect defaults can cause attackers to bypass rate limitations","id":"CVE-2022-2366","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mattermost:mattermost_server","products":["mattermost:mattermost_server"],"type":"misconfiguration","year":"2022"},"n_packages":1,"n_references":1,"next":{"headline":"WSM Downloader \u003c= 1.4.0 - Domain Name Restriction Bypass","id":"CVE-2022-2367"},"packages":[{"ecosystem":"Bitnami","fixed":["6.3.9","6.5.2","6.6.2"],"introduced":["0","6.4.0","6.6.0","6.7.0"],"last_affected":["6.7.0"],"package":"mattermost","purl":"pkg:bitnami/mattermost","source":"BIT-mattermost-2022-2366"}],"prev":{"headline":"Cross-site Scripting (XSS) - Stored in zadam/trilium","id":"CVE-2022-2365"},"products":["Mattermost"],"published":"2022-07-11","related":[{"cvss_score":9.9,"headline":"Account takeover on OAuth/OpenID-enabled servers","id":"CVE-2025-12419","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":9.9,"headline":"Account Takeover via Code Exchange Endpoint","id":"CVE-2025-12421","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":9.9,"headline":"Path Traversal Leading to RCE by Any Authenticated Mattermost User","id":"CVE-2025-4981","kev_date_added":null,"published":"2025-06-20"},{"cvss_score":9.9,"headline":"Arbitrary file read via block duplication in Mattermost Boards","id":"CVE-2025-20051","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":9.9,"headline":"Arbitrary file read in Mattermost Boards via import \u0026 export board archive","id":"CVE-2025-25279","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":9.8,"headline":"Mattermost Server: Insufficient Password-Reset Link Invalidation","id":"CVE-2016-11074","kev_date_added":null,"published":"2020-06-19"},{"cvss_score":9.8,"headline":"Mattermost Server allows attackers to gain privileges by accessing unintended API endpoints with users' credentials","id":"CVE-2017-18885","kev_date_added":null,"published":"2020-06-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-06","vendors":["Mattermost"]},"summary":"Attackers can bypass rate limits and manipulate audit logs by exploiting incorrect default trusted IP header settings in Mattermost.","url":"https://insights.sbomify.com/CVE-2022-2366/"}