# CVE-2022-23704: A potential security vulnerability has been identified in Integrated Lights-Out 4 (iLO 4).


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 9 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-jv6q-f63c-9wf2

## What is CVE-2022-23704?

CVE-2022-23704 is a high-severity vulnerability in HPE Integrated Lights-Out 4 (iLO 4), published on 9 May 2022. 

### Official description

A potential security vulnerability has been identified in Integrated Lights-Out 4 (iLO 4). The vulnerability could allow remote Denial of Service. The vulnerability is resolved in Integrated Lights-Out 4 (iLO 4) 2.80 and later.

## Which versions are affected by CVE-2022-23704?

It affects 1 product.


Products: Hp Integrated Lights-Out 4.

## How do I fix CVE-2022-23704?

No fix has been published for CVE-2022-23704 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-23704 being exploited?

There is no known exploitation of CVE-2022-23704 in the wild and no public exploit code.

## Other vulnerabilities in HPE Integrated Lights-Out 4 (iLO 4)

- [CVE-2023-28083](https://insights.sbomify.com/CVE-2023-28083/): Cross-site scripting in Integrated Lights-Out (high 8.3)
- [CVE-2013-4843](https://insights.sbomify.com/CVE-2013-4843/): Information disclosure in n/a (medium 6.8)
- [CVE-2021-29202](https://insights.sbomify.com/CVE-2021-29202/): Memory corruption in HPE Integrated Lights-Out 4 (iLO 4) For HPE Gen9 servers; HPE Integrated Lights-Out 5 (iLO 5) for HPE Gen10 Servers (medium 6.7)
- [CVE-2020-7202](https://insights.sbomify.com/CVE-2020-7202/): Information disclosure in HPE ProLiant Servers, Apollo Products, Converged Systems, and Synergy Compute Modules with Integrated Lights-Out 5 (iLO 5), or Integrated Lights-Out 4 (iLO 4) (medium 5.3)
- [CVE-2021-29201](https://insights.sbomify.com/CVE-2021-29201/): Cross-site scripting in HPE Integrated Lights-Out 4 (iLO 4) For HPE Gen9 servers; HPE Integrated Lights-Out 5 (iLO 5) for HPE Gen10 Servers (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23704 and fix it if it is affected.

What it is: CVE-2022-23704 is a high-severity vulnerability in HPE Integrated Lights-Out 4 (iLO 4), published on 9 May 2022. 
Exploitation: There is no known exploitation of CVE-2022-23704 in the wild and no public exploit code.

Affected product: HPE Integrated Lights-Out 4 (iLO 4). No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23704/ (Markdown: https://insights.sbomify.com/CVE-2022-23704/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23704
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23704
- OSV: https://osv.dev/vulnerability/CVE-2022-23704

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23704/
Summaries are generated and may contain mistakes; the official description above is the record.
