{"answers":{"affected":"3 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23708 in the wild and no public exploit code.","fix":"Upgrade org.elasticsearch:elasticsearch to 7.17.1 or later.","what":"CVE-2022-23708 is a medium-severity missing authorization vulnerability in Elastic Elasticsearch, published on 3 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23708 and fix it if it is affected.\n\nWhat it is: CVE-2022-23708 is a medium-severity missing authorization vulnerability in Elastic Elasticsearch, published on 3 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23708 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.elasticsearch:elasticsearch (Maven): affected from 7.16.0; fixed in 7.17.1\n- org.elasticsearch:elasticsearch (Maven): affected from 7.16.0; fixed in 7.17.1\n- elasticsearch (Bitnami): affected from 7.16.0; fixed in 7.17.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23708/ (Markdown: https://insights.sbomify.com/CVE-2022-23708/index.md)","id":"CVE-2022-23708","markdown":"https://insights.sbomify.com/CVE-2022-23708/index.md","name":"CVE-2022-23708","record":{"aliases":["BIT-elasticsearch-2022-23708","GHSA-pgq6-ccqj-hpqr","UBUNTU-CVE-2022-23708"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Elasticsearch search engine","requires_auth":"low_privilege","summary":"Authenticated users with wildcard index permissions can access the security index due to disabled protections during version upgrades.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"elastic","cpe":[{"product":"elasticsearch","vendor":"elastic"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-264","name":null}],"description":"A flaw was discovered in Elasticsearch 7.17.0’s upgrade assistant, in which upgrading from version 6.x to 7.x would disable the in-built protections on the security index, allowing authenticated users with “*” index permissions access to this index.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Elasticsearch privilege escalation","id":"CVE-2022-23708","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"elastic:elasticsearch","products":["elastic:elasticsearch"],"type":"missing_authorization","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Missing authorization in kibana","id":"CVE-2022-23709"},"packages":[{"ecosystem":"Bitnami","fixed":["7.17.1"],"introduced":["7.16.0"],"last_affected":[],"package":"elasticsearch","purl":"pkg:bitnami/elasticsearch","source":"BIT-elasticsearch-2022-23708"},{"ecosystem":"Maven","fixed":["7.17.1"],"introduced":["7.16.0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":null,"source":"GHSA-pgq6-ccqj-hpqr"},{"ecosystem":"Maven","fixed":["7.17.1"],"introduced":["7.16.0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":"pkg:maven/org.elasticsearch/elasticsearch","source":"GHSA-pgq6-ccqj-hpqr"}],"prev":{"headline":"Cross-site scripting in Kibana","id":"CVE-2022-23707"},"products":["elasticsearch"],"published":"2022-03-03","related":[{"cvss_score":9.8,"headline":"Elasticsearch Groovy Scripting Engine Remote Code Execution","id":"CVE-2015-1427","kev_date_added":"2022-03-25","published":"2015-02-17"},{"cvss_score":8.1,"headline":"Elasticsearch Remote Code Execution","id":"CVE-2014-3120","kev_date_added":"2022-03-25","published":"2014-07-28"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2015-5377","kev_date_added":null,"published":"2018-03-06"},{"cvss_score":8.8,"headline":"Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution","id":"CVE-2026-72649","kev_date_added":null,"published":"2026-09-01"},{"cvss_score":8.8,"headline":"Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process","id":"CVE-2026-72642","kev_date_added":null,"published":"2026-08-13"},{"cvss_score":8.8,"headline":"Privilege Escalation Flaw in Elasticsearch","id":"CVE-2020-7014","kev_date_added":null,"published":"2020-06-03"},{"cvss_score":8.8,"headline":"Improper Privilege Management in Elasticsearch","id":"CVE-2020-7009","kev_date_added":null,"published":"2020-03-31"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Elastic"]},"summary":"Authenticated users with wildcard index permissions can access the security index due to disabled protections during version upgrades.","url":"https://insights.sbomify.com/CVE-2022-23708/"}