# CVE-2022-23708: Elasticsearch privilege escalation

> Authenticated users with wildcard index permissions can access the security index due to disabled protections during version upgrades.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-elasticsearch-2022-23708, GHSA-pgq6-ccqj-hpqr, UBUNTU-CVE-2022-23708

## What is CVE-2022-23708?

CVE-2022-23708 is a medium-severity missing authorization vulnerability in Elastic Elasticsearch, published on 3 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was discovered in Elasticsearch 7.17.0’s upgrade assistant, in which upgrading from version 6.x to 7.x would disable the in-built protections on the security index, allowing authenticated users with “*” index permissions access to this index.

Weakness: CWE-264

## Which versions are affected by CVE-2022-23708?

3 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | From 7.16.0 | 7.17.1 |
| `org.elasticsearch:elasticsearch` | Maven | From 7.16.0 | 7.17.1 |
| `elasticsearch` | Bitnami | From 7.16.0 | 7.17.1 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2022-23708?

Upgrade org.elasticsearch:elasticsearch to 7.17.1 or later.

## Is CVE-2022-23708 being exploited?

There is no known exploitation of CVE-2022-23708 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23708 and fix it if it is affected.

What it is: CVE-2022-23708 is a medium-severity missing authorization vulnerability in Elastic Elasticsearch, published on 3 Mar 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23708 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected from 7.16.0; fixed in 7.17.1
- org.elasticsearch:elasticsearch (Maven): affected from 7.16.0; fixed in 7.17.1
- elasticsearch (Bitnami): affected from 7.16.0; fixed in 7.17.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23708/ (Markdown: https://insights.sbomify.com/CVE-2022-23708/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23708
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23708
- OSV: https://osv.dev/vulnerability/CVE-2022-23708

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23708/
Summaries are generated and may contain mistakes; the official description above is the record.
