CVE-2022-23733 Stored XSS vulnerability in GitHub Enterprise Server leading to injection of arbitrary attributes

Medium 5.4 Published Updated

Stored XSS in GitHub Enterprise Server allows injection of arbitrary attributes, potentially enabling code execution despite CSP mitigations.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2022-23733?

CVE-2022-23733 is a medium-severity cross-site scripting vulnerability in Github Enterprise Server, published on 2 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A stored XSS vulnerability was identified in GitHub Enterprise Server that allowed the injection of arbitrary attributes. This injection was blocked by Github's Content Security Policy (CSP). This vulnerability affected all versions of GitHub Enterprise Server prior to 3.6 and was fixed in versions 3.3.11, 3.4.6 and 3.5.3. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-79

Which versions are affected by CVE-2022-23733?

It affects 1 product.

Products include Github Enterprise Server.

How do I fix CVE-2022-23733?

No fix has been published for CVE-2022-23733 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-23733 being exploited?

There is no known exploitation of CVE-2022-23733 in the wild and no public exploit code.

All Github Enterprise Server vulnerabilities

Sources

Also known as GHSA-vmgc-h9g8-4wpc.

Is CVE-2022-23733 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free