# CVE-2022-23733: Stored XSS vulnerability in GitHub Enterprise Server leading to injection of arbitrary attributes

> Stored XSS in GitHub Enterprise Server allows injection of arbitrary attributes, potentially enabling code execution despite CSP mitigations.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 2 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-vmgc-h9g8-4wpc

## What is CVE-2022-23733?

CVE-2022-23733 is a medium-severity cross-site scripting vulnerability in Github Enterprise Server, published on 2 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A stored XSS vulnerability was identified in GitHub Enterprise Server that allowed the injection of arbitrary attributes. This injection was blocked by Github's Content Security Policy (CSP). This vulnerability affected all versions of GitHub Enterprise Server prior to 3.6 and was fixed in versions 3.3.11, 3.4.6 and 3.5.3. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-23733?

It affects 1 product.


Products: Github Enterprise Server.

## How do I fix CVE-2022-23733?

No fix has been published for CVE-2022-23733 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-23733 being exploited?

There is no known exploitation of CVE-2022-23733 in the wild and no public exploit code.

## Other vulnerabilities in Github Enterprise Server

- [CVE-2024-4985](https://insights.sbomify.com/CVE-2024-4985/): Auth bypass in Enterprise Server (critical 10.0)
- [CVE-2022-23739](https://insights.sbomify.com/CVE-2022-23739/): Missing authorization in GitHub Enterprise Server (critical 9.8)
- [CVE-2022-46255](https://insights.sbomify.com/CVE-2022-46255/): Improper Limitation of a Pathname to a Restricted Directory in GitHub Enterprise Server leading to RCE (critical 9.8)
- [CVE-2021-22869](https://insights.sbomify.com/CVE-2021-22869/): Improper access control in GitHub Enterprise Server allows self-hosted runners to execute outside their control group (critical 9.8)
- [CVE-2024-9487](https://insights.sbomify.com/CVE-2024-9487/): Auth bypass in Enterprise Server (critical 9.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23733 and fix it if it is affected.

What it is: CVE-2022-23733 is a medium-severity cross-site scripting vulnerability in Github Enterprise Server, published on 2 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23733 in the wild and no public exploit code.

Affected product: Github Enterprise Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23733/ (Markdown: https://insights.sbomify.com/CVE-2022-23733/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23733
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23733
- OSV: https://osv.dev/vulnerability/CVE-2022-23733

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23733/
Summaries are generated and may contain mistakes; the official description above is the record.
