CVE-2022-23737 Improper Privilege Management in GitHub Enterprise Server leading to page creation and deletion

Medium 6.5 Published Updated

Users with write permissions can improperly create or delete pages via the API, requiring an upgrade to GitHub Enterprise Server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2022-23737?

CVE-2022-23737 is a medium-severity vulnerability in Github Enterprise Server, published on 1 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An improper privilege management vulnerability was identified in GitHub Enterprise Server that allowed users with improper privileges to create or delete pages via the API. To exploit this vulnerability, an attacker would need to be added to an organization's repo with write permissions. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.7 and was fixed in versions 3.2.20, 3.3.15, 3.4.10, 3.5.7, and 3.6.3. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-269

Which versions are affected by CVE-2022-23737?

It affects 1 product.

Products include Github Enterprise Server.

How do I fix CVE-2022-23737?

No fix has been published for CVE-2022-23737 yet. Limit exposure of the affected software until one is available.

Is CVE-2022-23737 being exploited?

There is no known exploitation of CVE-2022-23737 in the wild and no public exploit code.

All Github Enterprise Server vulnerabilities

Sources

Also known as GHSA-2pm2-h49w-3rj5.

Is CVE-2022-23737 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free