CVE-2022-23738 Incomplete cache verification issue in GitHub Enterprise Server leading to exposure of private repo files

Medium 5.7 Published Updated

An attacker with limited access can expose private repository files by tricking an administrator into visiting a crafted URL due to improper cache verification.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2022-23738?

CVE-2022-23738 is a medium-severity vulnerability in Github Enterprise Server, published on 1 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An improper cache key vulnerability was identified in GitHub Enterprise Server that allowed an unauthorized actor to access private repository files through a public repository. To exploit this, an actor would need to already be authorized on the GitHub Enterprise Server instance, be able to create a public repository, and have a site administrator visit a specially crafted URL. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.6 and was fixed in versions 3.2.20, 3.3.15, 3.4.10, 3.5.7, 3.6.3. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-552, CWE-200

Which versions are affected by CVE-2022-23738?

It affects 1 product.

Products include Github Enterprise Server.

How do I fix CVE-2022-23738?

No fix has been published for CVE-2022-23738 yet. Limit exposure of the affected software until one is available.

Is CVE-2022-23738 being exploited?

There is no known exploitation of CVE-2022-23738 in the wild and no public exploit code.

All Github Enterprise Server vulnerabilities

Sources

Also known as GHSA-vf64-jp2j-qwc6.

Is CVE-2022-23738 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free