# CVE-2022-23772: Integer overflow in n/a

> An integer overflow in Go's math/big package allows attackers to cause uncontrolled memory consumption, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-8512, BIT-golang-2022-23772, DEBIAN-CVE-2022-23772, GHSA-q99m-p7hq-5v4f, GO-2021-0317, RHSA-2024:5754, UBUNTU-CVE-2022-23772

## What is CVE-2022-23772?

CVE-2022-23772 is a high-severity vulnerability in Debian Debian Linux, published on 11 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rat.SetString in math/big in Go before 1.16.14 and 1.17.x before 1.17.7 has an overflow that can lead to Uncontrolled Memory Consumption.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2022-23772?

2 open source packages ship an affected version, including golang and stdlib. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `golang` | Bitnami | All versions | 1.16.14, 1.17.7 |
| `stdlib` | Go | All versions | 1.16.14, 1.17.7 |
| `openshift` | Red Hat:openshift:4.15::el8 | All versions | 0:4.15.0-202408131909.p0.gbc3c7c5.assembly.stream.el8 |
| `openshift-hyperkube` | Red Hat:openshift:4.15::el8 | All versions | 0:4.15.0-202408131909.p0.gbc3c7c5.assembly.stream.el8 |
| `openshift` | Red Hat:openshift:4.15::el9 | All versions | 0:4.15.0-202408131909.p0.gbc3c7c5.assembly.stream.el9 |
| `openshift-hyperkube` | Red Hat:openshift:4.15::el9 | All versions | 0:4.15.0-202408131909.p0.gbc3c7c5.assembly.stream.el9 |

Products: Debian Debian Linux, Golang Go, Netapp Beegfs Csi Driver, Netapp Cloud Insights Telegraf Agent, Netapp Kubernetes Monitoring Operator, Netapp Storagegrid.

## How do I fix CVE-2022-23772?

Upgrade golang to a fixed version for your release line: 1.16.14 or 1.17.7.

## Is CVE-2022-23772 being exploited?

There is no known exploitation of CVE-2022-23772 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23772 and fix it if it is affected.

What it is: CVE-2022-23772 is a high-severity vulnerability in Debian Debian Linux, published on 11 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23772 in the wild and no public exploit code.

Affected packages and fixed versions:
- golang (Bitnami): affected all versions; fixed in 1.16.14, 1.17.7
- stdlib (Go): affected all versions; fixed in 1.16.14, 1.17.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23772/ (Markdown: https://insights.sbomify.com/CVE-2022-23772/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23772
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23772
- OSV: https://osv.dev/vulnerability/CVE-2022-23772

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23772/
Summaries are generated and may contain mistakes; the official description above is the record.
