# CVE-2022-23793: [20220301] - Core - Zip Slip within the Tar extractor

> Attackers can write files outside intended directories via crafted tar archives, potentially leading to code execution or data modification in Joomla CMS.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2022
- **Updated:** 25 Feb 2026
- **Also known as:** BIT-joomla-2022-23793, GHSA-jm67-jh3g-cg3f

## What is CVE-2022-23793?

CVE-2022-23793 is a high-severity path traversal vulnerability in Joomla Joomla\!, published on 30 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Joomla! 3.0.0 through 3.10.6 & 4.0.0 through 4.1.0. Extracting an specifilcy crafted tar package could write files outside of the intended path.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-23793?

5 open source packages ship an affected version, including joomla/archive and joomla. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joomla/archive` | Packagist | All versions | 1.1.12 |
| `joomla/archive` | Packagist | All versions | 1.1.12 |
| `joomla/archive` | Packagist | From 2.0.0 | 2.0.1 |
| `joomla/archive` | Packagist | From 2.0.0 | 2.0.1 |
| `joomla` | Bitnami | From 3.0.0 to 3.10.6 | None |

Products: Joomla Joomla\!.

## How do I fix CVE-2022-23793?

Upgrade joomla/archive to a fixed version for your release line: 1.1.12 or 2.0.1.

## Is CVE-2022-23793 being exploited?

There is no known exploitation of CVE-2022-23793 in the wild and no public exploit code.

## Other vulnerabilities in Joomla Joomla\!

- [CVE-2016-10033](https://insights.sbomify.com/CVE-2016-10033/): PHPMailer Command Injection (critical 9.8, exploited in the wild)
- [CVE-2023-23752](https://insights.sbomify.com/CVE-2023-23752/): Joomla! Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-48902](https://insights.sbomify.com/CVE-2026-48902/): Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links (critical 9.8)
- [CVE-2025-25226](https://insights.sbomify.com/CVE-2025-25226/): [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package (critical 9.8)
- [CVE-2022-23795](https://insights.sbomify.com/CVE-2022-23795/): [20220303] - Core - User row are not bound to a authentication mechanism (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23793 and fix it if it is affected.

What it is: CVE-2022-23793 is a high-severity path traversal vulnerability in Joomla Joomla\!, published on 30 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23793 in the wild and no public exploit code.

Affected packages and fixed versions:
- joomla/archive (Packagist): affected all versions; fixed in 1.1.12
- joomla/archive (Packagist): affected all versions; fixed in 1.1.12
- joomla/archive (Packagist): affected from 2.0.0; fixed in 2.0.1
- joomla/archive (Packagist): affected from 2.0.0; fixed in 2.0.1
- joomla (Bitnami): affected from 3.0.0 up to 3.10.6; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23793/ (Markdown: https://insights.sbomify.com/CVE-2022-23793/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23793
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23793
- OSV: https://osv.dev/vulnerability/CVE-2022-23793

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23793/
Summaries are generated and may contain mistakes; the official description above is the record.
