# CVE-2022-23799: [20220307] - Core - Variable Tampering on JInput $_REQUEST data

> Attackers can tamper with input data in Joomla CMS due to improper handling of request variables, potentially altering application state or accessing data.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2022
- **Updated:** 25 Feb 2026
- **Also known as:** BIT-joomla-2022-23799, GHSA-49fj-qp6p-q544

## What is CVE-2022-23799?

CVE-2022-23799 is a critical vulnerability in Joomla Joomla\!, published on 30 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Joomla! 4.0.0 through 4.1.0. Under specific circumstances, JInput pollutes method-specific input bags with $_REQUEST data.

## Which versions are affected by CVE-2022-23799?

3 open source packages ship an affected version, including joomla/input and joomla. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joomla/input` | Packagist | From 2.0.0 | 2.0.2 |
| `joomla/input` | Packagist | From 2.0.0 | 2.0.2 |
| `joomla` | Bitnami | From 4.0.0 to 4.1.0 | None |

Products: Joomla Joomla\!.

## How do I fix CVE-2022-23799?

Upgrade joomla/input to 2.0.2 or later.

## Is CVE-2022-23799 being exploited?

There is no known exploitation of CVE-2022-23799 in the wild and no public exploit code.

## Other vulnerabilities in Joomla Joomla\!

- [CVE-2016-10033](https://insights.sbomify.com/CVE-2016-10033/): PHPMailer Command Injection (critical 9.8, exploited in the wild)
- [CVE-2023-23752](https://insights.sbomify.com/CVE-2023-23752/): Joomla! Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-48902](https://insights.sbomify.com/CVE-2026-48902/): Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links (critical 9.8)
- [CVE-2025-25226](https://insights.sbomify.com/CVE-2025-25226/): [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package (critical 9.8)
- [CVE-2022-23795](https://insights.sbomify.com/CVE-2022-23795/): [20220303] - Core - User row are not bound to a authentication mechanism (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23799 and fix it if it is affected.

What it is: CVE-2022-23799 is a critical vulnerability in Joomla Joomla\!, published on 30 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23799 in the wild and no public exploit code.

Affected packages and fixed versions:
- joomla/input (Packagist): affected from 2.0.0; fixed in 2.0.2
- joomla/input (Packagist): affected from 2.0.0; fixed in 2.0.2
- joomla (Bitnami): affected from 4.0.0 up to 4.1.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23799/ (Markdown: https://insights.sbomify.com/CVE-2022-23799/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23799
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23799
- OSV: https://osv.dev/vulnerability/CVE-2022-23799

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23799/
Summaries are generated and may contain mistakes; the official description above is the record.
