CVE-2022-23800 [20220308] - Core - Inadequate content filtering within the filter code

Medium 6.1 Published Updated

Inadequate content filtering in Joomla allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-23800?

CVE-2022-23800 is a medium-severity cross-site scripting vulnerability in Joomla Joomla\!, published on 30 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

An issue was discovered in Joomla! 4.0.0 through 4.1.0. Inadequate content filtering leads to XSS vulnerabilities in various components.

Weakness: CWE-79

Which versions are affected by CVE-2022-23800?

5 open source packages ship an affected version, including joomla/filter and joomla. It affects 1 product.

PackageAffectedFixed in
joomla/filter PackagistAll versions1.4.4
joomla/filter PackagistAll versions1.4.4
joomla/filter PackagistFrom 2.0.02.0.1
joomla/filter PackagistFrom 2.0.02.0.1
joomla BitnamiFrom 4.0.0 to 4.1.0None

Products include Joomla Joomla\!.

How do I fix CVE-2022-23800?

Upgrade joomla/filter to a fixed version for your release line: 1.4.4 or 2.0.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-23800 being exploited?

There is no known exploitation of CVE-2022-23800 in the wild and no public exploit code.

All Joomla Joomla\! vulnerabilities

Sources

Also known as BIT-joomla-2022-23800, GHSA-qcv6-h33g-hvrc, MINI-vjw5-3hhv-68v7.

Is CVE-2022-23800 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free