CVE-2022-23806 Other in n/a
The Go standard library incorrectly validates elliptic curve points, potentially allowing invalid field elements to be accepted as valid.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-23806?
CVE-2022-23806 is a critical vulnerability in Debian Debian Linux, published on 11 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Curve.IsOnCurve in crypto/elliptic in Go before 1.16.14 and 1.17.x before 1.17.7 can incorrectly return true in situations with a big.Int value that is not a valid field element.
Weakness: CWE-252
Which versions are affected by CVE-2022-23806?
2 open source packages ship an affected version, including golang and stdlib. It affects 6 products.
| Package | Affected | Fixed in |
|---|---|---|
golang Bitnami | All versions | 1.16.14, 1.17.7 |
stdlib Go | All versions | 1.16.14, 1.17.7 |
Products include Debian Debian Linux, Golang Go, Netapp Beegfs Csi Driver, Netapp Cloud Insights Telegraf Agent, Netapp Kubernetes Monitoring Operator, Netapp Storagegrid.
How do I fix CVE-2022-23806?
Upgrade golang to a fixed version for your release line: 1.16.14 or 1.17.7.
Is CVE-2022-23806 being exploited?
There is no known exploitation of CVE-2022-23806 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as AZL-79100, AZL-8524, AZL-98838, BIT-golang-2022-23806, DEBIAN-CVE-2022-23806, GHSA-8c83-vp4v-h7fq and 2 more.