{"answers":{"affected":"3 open source packages ship an affected version, including phpmyadmin/phpmyadmin and phpmyadmin. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23808 exists.","fix":"Upgrade phpmyadmin/phpmyadmin to 5.1.2 or later.","what":"CVE-2022-23808 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 22 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-23808 and fix it if it is affected.\n\nWhat it is: CVE-2022-23808 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 22 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23808 exists.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 5.1.0; fixed in 5.1.2\n- phpmyadmin/phpmyadmin (Packagist): affected from 5.1.0; fixed in 5.1.2\n- phpmyadmin (Bitnami): affected from 5.1.0; fixed in 5.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23808/ (Markdown: https://insights.sbomify.com/CVE-2022-23808/index.md)","id":"CVE-2022-23808","markdown":"https://insights.sbomify.com/CVE-2022-23808/index.md","name":"CVE-2022-23808","record":{"aliases":["BIT-phpmyadmin-2022-23808","DEBIAN-CVE-2022-23808","GHSA-vcwc-6mr9-8m7c","UBUNTU-CVE-2022-23808"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"phpMyAdmin","requires_auth":"none","summary":"Attackers can inject malicious code into the phpMyAdmin setup script, enabling XSS or HTML injection attacks against administrators.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in phpMyAdmin 5.1 before 5.1.2. An attacker can inject malicious code into aspects of the setup script, which can allow XSS or HTML injection.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":"2022-02-01","github_poc":1,"max_poc_stars":115,"metasploit":0,"nuclei":1,"refs":[{"date":"2022-02-01T17:02:03Z","kind":"github_poc","ref":"https://github.com/dipakpanchal05/CVE-2022-23808","stars":115,"title":"phpMyAdmin XSS "},{"date":null,"kind":"nuclei","ref":"http/cves/2022/CVE-2022-23808.yaml","stars":null,"title":"phpMyAdmin \u003c 5.1.2 - Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"Cross-site Scripting in phpmyadmin","id":"CVE-2022-23808","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"phpmyadmin:phpmyadmin","products":["phpmyadmin:phpmyadmin"],"type":"xss","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"Code injection in a-blog cms","id":"CVE-2022-23810"},"packages":[{"ecosystem":"Bitnami","fixed":["5.1.2"],"introduced":["5.1.0"],"last_affected":[],"package":"phpmyadmin","purl":"pkg:bitnami/phpmyadmin","source":"BIT-phpmyadmin-2022-23808"},{"ecosystem":"Packagist","fixed":["5.1.2"],"introduced":["5.1.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-vcwc-6mr9-8m7c"},{"ecosystem":"Packagist","fixed":["5.1.2"],"introduced":["5.1.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-vcwc-6mr9-8m7c"}],"prev":{"headline":"Improper Authentication in phpmyadmin","id":"CVE-2022-23807"},"products":["n/a"],"published":"2022-01-22","related":[{"cvss_score":10,"headline":"Misconfiguration in n/a","id":"CVE-2008-7251","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"phpMyAdmin unsafely handles temporary files","id":"CVE-2008-7252","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-0203","kev_date_added":null,"published":"2007-01-11"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2004-1147","kev_date_added":null,"published":"2004-12-15"},{"cvss_score":9.8,"headline":"phpmyadmin contains SQL Injection vulnerability","id":"CVE-2020-22452","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-11768","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-05","vendors":["n/a"]},"summary":"Attackers can inject malicious code into the phpMyAdmin setup script, enabling XSS or HTML injection attacks against administrators.","url":"https://insights.sbomify.com/CVE-2022-23808/"}