CVE-2022-23833 Infinite Loop in Django
Attackers can cause a denial of service via infinite loop in Django's MultiPartParser by sending crafted multipart form inputs.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-23833?
CVE-2022-23833 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 3 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in MultiPartParser in Django 2.2 before 2.2.27, 3.2 before 3.2.12, and 4.0 before 4.0.2. Passing certain inputs to multipart forms could result in an infinite loop when parsing files.
Weakness: CWE-835
Which versions are affected by CVE-2022-23833?
8 open source packages ship an affected version, including django and Django. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 2.2.0 | 2.2.27, 3.2.12, 4.0.2 |
django PyPI | From 2.2 | 2.2.27, 3.2.12, 4.0.2 |
django PyPI | From 2.2 | 2.2.27 |
django PyPI | From 3.2 | 3.2.12 |
django PyPI | From 4.0 | 4.0.2 |
Django PyPI | From 2.2 | 2.2.27 |
2 more packages
Django PyPI | From 3.2 | 3.2.12 |
Django PyPI | From 4.0 | 4.0.2 |
Products include Debian Debian Linux, Djangoproject Django, Fedoraproject Fedora.
How do I fix CVE-2022-23833?
Upgrade django to a fixed version for your release line: 2.2.27, 3.2.12 or 4.0.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-23833 being exploited?
There is no known exploitation of CVE-2022-23833 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-django-2022-23833, CLSA-2025-1761696690, DEBIAN-CVE-2022-23833, GHSA-6cw3-g6wv-c2xv, PYSEC-2022-20, UBUNTU-CVE-2022-23833.