CVE-2022-23837 Denial of service in sidekiq
Attackers can cause denial of service in the Sidekiq Web UI by requesting unlimited stats, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-23837?
CVE-2022-23837 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 21 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In api.rb in Sidekiq before 5.2.10 and 6.4.0, there is no limit on the number of days when requesting stats for the graph. This overloads the system, affecting the Web UI, and makes it unavailable to users.
Weakness: CWE-770
Which versions are affected by CVE-2022-23837?
4 open source packages ship an affected version, including sidekiq. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
sidekiq RubyGems | All versions | 5.2.10 |
sidekiq RubyGems | All versions | 5.2.10 |
sidekiq RubyGems | From 6.0.0 | 6.4.0 |
sidekiq RubyGems | From 6.0.0 | 6.4.0 |
Products include Contribsys Sidekiq, Debian Debian Linux.
How do I fix CVE-2022-23837?
Upgrade sidekiq to a fixed version for your release line: 5.2.10 or 6.4.0.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-23837 being exploited?
There is no known exploitation of CVE-2022-23837 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2022-23837, GHSA-jrfj-98qg-qjgv, UBUNTU-CVE-2022-23837.