{"answers":{"affected":"4 open source packages ship an affected version, including sidekiq. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-23837 in the wild and no public exploit code.","fix":"Upgrade sidekiq to a fixed version for your release line: 5.2.10 or 6.4.0.","what":"CVE-2022-23837 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 21 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23837 and fix it if it is affected.\n\nWhat it is: CVE-2022-23837 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 21 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23837 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sidekiq (RubyGems): affected all versions; fixed in 5.2.10\n- sidekiq (RubyGems): affected all versions; fixed in 5.2.10\n- sidekiq (RubyGems): affected from 6.0.0; fixed in 6.4.0\n- sidekiq (RubyGems): affected from 6.0.0; fixed in 6.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23837/ (Markdown: https://insights.sbomify.com/CVE-2022-23837/index.md)","id":"CVE-2022-23837","markdown":"https://insights.sbomify.com/CVE-2022-23837/index.md","name":"CVE-2022-23837","record":{"aliases":["DEBIAN-CVE-2022-23837","GHSA-jrfj-98qg-qjgv","UBUNTU-CVE-2022-23837"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Sidekiq Ruby library","requires_auth":"none","summary":"Attackers can cause denial of service in the Sidekiq Web UI by requesting unlimited stats, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"sidekiq","vendor":"contribsys"},{"product":"debian_linux","vendor":"debian"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"In api.rb in Sidekiq before 5.2.10 and 6.4.0, there is no limit on the number of days when requesting stats for the graph. This overloads the system, affecting the Web UI, and makes it unavailable to users.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in sidekiq","id":"CVE-2022-23837","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"denial_of_service","year":"2022"},"n_packages":4,"n_references":5,"next":{"headline":"Command injection in Alluxio","id":"CVE-2022-23848"},"packages":[{"ecosystem":"RubyGems","fixed":["5.2.10"],"introduced":["0"],"last_affected":[],"package":"sidekiq","purl":null,"source":"GHSA-jrfj-98qg-qjgv"},{"ecosystem":"RubyGems","fixed":["5.2.10"],"introduced":["0"],"last_affected":[],"package":"sidekiq","purl":"pkg:gem/sidekiq","source":"GHSA-jrfj-98qg-qjgv"},{"ecosystem":"RubyGems","fixed":["6.4.0"],"introduced":["6.0.0"],"last_affected":[],"package":"sidekiq","purl":null,"source":"GHSA-jrfj-98qg-qjgv"},{"ecosystem":"RubyGems","fixed":["6.4.0"],"introduced":["6.0.0"],"last_affected":[],"package":"sidekiq","purl":"pkg:gem/sidekiq","source":"GHSA-jrfj-98qg-qjgv"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2022-23835"},"products":["n/a"],"published":"2022-01-21","related":[{"cvss_score":8.3,"headline":"Cross-site Scripting (XSS) - Reflected in sidekiq/sidekiq","id":"CVE-2023-1892","kev_date_added":null,"published":"2023-04-05"},{"cvss_score":7.5,"headline":"sidekiq Denial of Service vulnerability","id":"CVE-2023-26141","kev_date_added":null,"published":"2023-09-14"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2023-46950","kev_date_added":null,"published":"2024-03-01"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2023-46951","kev_date_added":null,"published":"2024-03-01"},{"cvss_score":6.1,"headline":"Cross-site Scripting in Sidekiq","id":"CVE-2021-30151","kev_date_added":null,"published":"2021-04-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can cause denial of service in the Sidekiq Web UI by requesting unlimited stats, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2022-23837/"}