# CVE-2022-23837: Denial of service in sidekiq

> Attackers can cause denial of service in the Sidekiq Web UI by requesting unlimited stats, requiring an upgrade to patched versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-23837, GHSA-jrfj-98qg-qjgv, UBUNTU-CVE-2022-23837

## What is CVE-2022-23837?

CVE-2022-23837 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 21 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In api.rb in Sidekiq before 5.2.10 and 6.4.0, there is no limit on the number of days when requesting stats for the graph. This overloads the system, affecting the Web UI, and makes it unavailable to users.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2022-23837?

4 open source packages ship an affected version, including sidekiq. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sidekiq` | RubyGems | All versions | 5.2.10 |
| `sidekiq` | RubyGems | All versions | 5.2.10 |
| `sidekiq` | RubyGems | From 6.0.0 | 6.4.0 |
| `sidekiq` | RubyGems | From 6.0.0 | 6.4.0 |

Products: Contribsys Sidekiq, Debian Debian Linux.

## How do I fix CVE-2022-23837?

Upgrade sidekiq to a fixed version for your release line: 5.2.10 or 6.4.0.

## Is CVE-2022-23837 being exploited?

There is no known exploitation of CVE-2022-23837 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2023-1892](https://insights.sbomify.com/CVE-2023-1892/): Cross-site Scripting (XSS) - Reflected in sidekiq/sidekiq (high 8.3)
- [CVE-2023-26141](https://insights.sbomify.com/CVE-2023-26141/): sidekiq Denial of Service vulnerability (high 7.5)
- [CVE-2023-46950](https://insights.sbomify.com/CVE-2023-46950/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2023-46951](https://insights.sbomify.com/CVE-2023-46951/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2021-30151](https://insights.sbomify.com/CVE-2021-30151/): Cross-site Scripting in Sidekiq (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23837 and fix it if it is affected.

What it is: CVE-2022-23837 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 21 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23837 in the wild and no public exploit code.

Affected packages and fixed versions:
- sidekiq (RubyGems): affected all versions; fixed in 5.2.10
- sidekiq (RubyGems): affected all versions; fixed in 5.2.10
- sidekiq (RubyGems): affected from 6.0.0; fixed in 6.4.0
- sidekiq (RubyGems): affected from 6.0.0; fixed in 6.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23837/ (Markdown: https://insights.sbomify.com/CVE-2022-23837/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23837
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23837
- OSV: https://osv.dev/vulnerability/CVE-2022-23837

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23837/
Summaries are generated and may contain mistakes; the official description above is the record.
