# CVE-2022-23848: Command injection in Alluxio


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-j3ch-vjph-8q6v

## What is CVE-2022-23848?

CVE-2022-23848 is a critical vulnerability in n/a, published on 20 Feb 2022. 

### Official description

In Alluxio before 2.7.3, the logserver does not validate the input stream. NOTE: this is not the same as the CVE-2021-44228 Log4j vulnerability.

## Which versions are affected by CVE-2022-23848?

2 open source packages ship an affected version, including org.alluxio:alluxio-core-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.alluxio:alluxio-core-common` | Maven | All versions | 2.7.3 |
| `org.alluxio:alluxio-core-common` | Maven | All versions | 2.7.3 |

Products: Alluxio Alluxio.

## How do I fix CVE-2022-23848?

Upgrade org.alluxio:alluxio-core-common to 2.7.3 or later.

## Is CVE-2022-23848 being exploited?

There is no known exploitation of CVE-2022-23848 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-38889](https://insights.sbomify.com/CVE-2023-38889/): Alluxio vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2020-21485](https://insights.sbomify.com/CVE-2020-21485/): Alluxio Cross Site Scripting vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23848 and fix it if it is affected.

What it is: CVE-2022-23848 is a critical vulnerability in n/a, published on 20 Feb 2022. 
Exploitation: There is no known exploitation of CVE-2022-23848 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.alluxio:alluxio-core-common (Maven): affected all versions; fixed in 2.7.3
- org.alluxio:alluxio-core-common (Maven): affected all versions; fixed in 2.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23848/ (Markdown: https://insights.sbomify.com/CVE-2022-23848/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23848
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23848
- OSV: https://osv.dev/vulnerability/CVE-2022-23848

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23848/
Summaries are generated and may contain mistakes; the official description above is the record.
