{"answers":{"affected":"3 open source packages ship an affected version, including sigs.k8s.io/aws-iam-authenticator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-2385 in the wild and no public exploit code.","fix":"Upgrade sigs.k8s.io/aws-iam-authenticator to 0.5.9 or later.","what":"CVE-2022-2385 is a high-severity authentication bypass vulnerability in Kubernetes aws-iam-authenticator, published on 12 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-2385 and fix it if it is affected.\n\nWhat it is: CVE-2022-2385 is a high-severity authentication bypass vulnerability in Kubernetes aws-iam-authenticator, published on 12 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-2385 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sigs.k8s.io/aws-iam-authenticator (Go): affected all versions; fixed in 0.5.9\n- sigs.k8s.io/aws-iam-authenticator (Go): affected all versions; fixed in 0.5.9\n- sigs.k8s.io/aws-iam-authenticator (Go): affected all versions; fixed in 0.5.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2385/ (Markdown: https://insights.sbomify.com/CVE-2022-2385/index.md)","id":"CVE-2022-2385","markdown":"https://insights.sbomify.com/CVE-2022-2385/index.md","name":"CVE-2022-2385","record":{"aliases":["GHSA-pp3f-98qg-5g75","GO-2022-0547","SUSE-SU-2022:2583-1"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Kubernetes IAM authenticator","requires_auth":"low_privilege","summary":"An allow-listed IAM identity can modify their username to escalate privileges in the aws-iam-authenticator component.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"kubernetes","cpe":[{"product":"aws-iam-authenticator","vendor":"kubernetes"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A security issue was discovered in aws-iam-authenticator where an allow-listed IAM identity may be able to modify their username and escalate privileges.","ecosystems":["Go","SUSE:Linux Enterprise Module for Public Cloud 15","SUSE:Linux Enterprise Module for Public Cloud 15 SP1","SUSE:Linux Enterprise Module for Public Cloud 15 SP2","SUSE:Linux Enterprise Module for Public Cloud 15 SP3","SUSE:Linux Enterprise Module for Public Cloud 15 SP4","openSUSE:Leap 15.3","openSUSE:Leap 15.4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AccessKeyID validation bypass","id":"CVE-2022-2385","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2022"},"n_packages":10,"n_references":2,"next":{"headline":"Crowdsignal Polls \u0026 Ratings \u003c 3.0.8 - Reflected Cross-Site Scripting","id":"CVE-2022-2386"},"packages":[{"ecosystem":"Go","fixed":["0.5.9"],"introduced":["0"],"last_affected":[],"package":"sigs.k8s.io/aws-iam-authenticator","purl":null,"source":"GHSA-pp3f-98qg-5g75"},{"ecosystem":"Go","fixed":["0.5.9"],"introduced":["0"],"last_affected":[],"package":"sigs.k8s.io/aws-iam-authenticator","purl":"pkg:golang/sigs.k8s.io/aws-iam-authenticator","source":"GHSA-pp3f-98qg-5g75"},{"ecosystem":"Go","fixed":["0.5.9"],"introduced":["0"],"last_affected":[],"package":"sigs.k8s.io/aws-iam-authenticator","purl":"pkg:golang/sigs.k8s.io/aws-iam-authenticator","source":"GO-2022-0547"},{"ecosystem":"SUSE:Linux Enterprise Module for Public Cloud 15","fixed":["0.5.3-150000.1.9.1"],"introduced":["0"],"last_affected":[],"package":"aws-iam-authenticator","purl":"pkg:rpm/suse/aws-iam-authenticator\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Public%20Cloud%2015","source":"SUSE-SU-2022:2583-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Public Cloud 15 SP1","fixed":["0.5.3-150000.1.9.1"],"introduced":["0"],"last_affected":[],"package":"aws-iam-authenticator","purl":"pkg:rpm/suse/aws-iam-authenticator\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Public%20Cloud%2015%20SP1","source":"SUSE-SU-2022:2583-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Public Cloud 15 SP2","fixed":["0.5.3-150000.1.9.1"],"introduced":["0"],"last_affected":[],"package":"aws-iam-authenticator","purl":"pkg:rpm/suse/aws-iam-authenticator\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Public%20Cloud%2015%20SP2","source":"SUSE-SU-2022:2583-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Public Cloud 15 SP3","fixed":["0.5.3-150000.1.9.1"],"introduced":["0"],"last_affected":[],"package":"aws-iam-authenticator","purl":"pkg:rpm/suse/aws-iam-authenticator\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Public%20Cloud%2015%20SP3","source":"SUSE-SU-2022:2583-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Public Cloud 15 SP4","fixed":["0.5.3-150000.1.9.1"],"introduced":["0"],"last_affected":[],"package":"aws-iam-authenticator","purl":"pkg:rpm/suse/aws-iam-authenticator\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Public%20Cloud%2015%20SP4","source":"SUSE-SU-2022:2583-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["0.5.3-150000.1.9.1"],"introduced":["0"],"last_affected":[],"package":"aws-iam-authenticator","purl":"pkg:rpm/opensuse/aws-iam-authenticator\u0026distro=openSUSE%20Leap%2015.3","source":"SUSE-SU-2022:2583-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["0.5.3-150000.1.9.1"],"introduced":["0"],"last_affected":[],"package":"aws-iam-authenticator","purl":"pkg:rpm/opensuse/aws-iam-authenticator\u0026distro=openSUSE%20Leap%2015.4","source":"SUSE-SU-2022:2583-1"}],"prev":{"headline":"Digital Publications by Supsystic \u003c 1.7.4 - Admin+ Stored Cross-Site Scripting","id":"CVE-2022-2384"},"products":["aws-iam-authenticator"],"published":"2022-07-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Kubernetes"]},"summary":"An allow-listed IAM identity can modify their username to escalate privileges in the aws-iam-authenticator component.","url":"https://insights.sbomify.com/CVE-2022-2385/"}