{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-23853 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-23853 is a high-severity command injection vulnerability in n/a, published on 11 Feb 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-23853 and fix it if it is affected.\n\nWhat it is: CVE-2022-23853 is a high-severity command injection vulnerability in n/a, published on 11 Feb 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-23853 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23853/ (Markdown: https://insights.sbomify.com/CVE-2022-23853/index.md)","id":"CVE-2022-23853","markdown":"https://insights.sbomify.com/CVE-2022-23853/index.md","name":"CVE-2022-23853","record":{"aliases":["DEBIAN-CVE-2022-23853","GHSA-qjh4-6jqf-7749","UBUNTU-CVE-2022-23853","openSUSE-SU-2024:11801-1","openSUSE-SU-2024:11813-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"KDE Kate text editor","requires_auth":"none","summary":"Attackers can execute arbitrary code by placing a malicious LSP server binary in a directory opened by the user in KDE Kate.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"kate","vendor":"kde"},{"product":"ktexteditor","vendor":"kde"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-427","name":"Uncontrolled Search Path Element"}],"description":"The LSP (Language Server Protocol) plugin in KDE Kate before 21.12.2 and KTextEditor before 5.91.0 tries to execute the associated LSP server binary when opening a file of a given type. If this binary is absent from the PATH, it will try running the LSP server binary in the directory of the file that was just opened (due to a misunderstanding of the QProcess API, that was never intended). This can be an untrusted directory.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection in n/a","id":"CVE-2022-23853","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Path traversal in InTouch Access Anywhere","id":"CVE-2022-23854"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["21.12.2-1.1"],"introduced":["0"],"last_affected":[],"package":"kate","purl":"pkg:rpm/opensuse/kate\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11801-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.15.2+kde294-2.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtbase","purl":"pkg:rpm/opensuse/libqt5-qtbase\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11813-1"}],"prev":{"headline":"Integer overflow in n/a","id":"CVE-2022-23852"},"products":["n/a"],"published":"2022-02-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code by placing a malicious LSP server binary in a directory opened by the user in KDE Kate.","url":"https://insights.sbomify.com/CVE-2022-23853/"}