CVE-2022-23896 Cross-site Scripting in admidio

Medium 5.4 Published Updated

Stored cross-site scripting in Admidio allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-23896?

CVE-2022-23896 is a medium-severity cross-site scripting vulnerability in n/a, published on 28 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Admidio 4.1.2 version is affected by stored cross-site scripting (XSS).

Weakness: CWE-79

Which versions are affected by CVE-2022-23896?

2 open source packages ship an affected version, including admidio/admidio. It affects 1 product.

PackageAffectedFixed in
admidio/admidio PackagistAll versions4.1.3
admidio/admidio PackagistAll versions4.1.3

Products include Admidio Admidio.

How do I fix CVE-2022-23896?

Upgrade admidio/admidio to 4.1.3 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-23896 being exploited?

There is no known exploitation of CVE-2022-23896 in the wild and no public exploit code.

Sources

Also known as GHSA-qr6m-f3gv-8678.

Is CVE-2022-23896 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free