# CVE-2022-23913: Apache ActiveMQ Artemis DoS

> An attacker can cause a denial of service in Apache ActiveMQ Artemis by triggering uncontrolled memory consumption.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-pr38-qpxm-g88x

## What is CVE-2022-23913?

CVE-2022-23913 is a high-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 4 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache ActiveMQ Artemis prior to 2.20.0 or 2.19.1, an attacker could partially disrupt availability (DoS) through uncontrolled resource consumption of memory.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2022-23913?

2 open source packages ship an affected version, including org.apache.activemq:artemis-core-client. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:artemis-core-client` | Maven | All versions | 2.19.1 |
| `org.apache.activemq:artemis-core-client` | Maven | All versions | 2.19.1 |

Products: Apache Artemis, Netapp Active Iq Unified Manager, Netapp Oncommand Workflow Automation.

## How do I fix CVE-2022-23913?

Upgrade org.apache.activemq:artemis-core-client to 2.19.1 or later.

## Is CVE-2022-23913 being exploited?

There is no known exploitation of CVE-2022-23913 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2026-57967](https://insights.sbomify.com/CVE-2026-57967/): Apache Artemis, Apache ActiveMQ Artemis: Missing authentication on CORE protocol session reattachment (critical 9.8)
- [CVE-2026-27446](https://insights.sbomify.com/CVE-2026-27446/): Apache Artemis, Apache ActiveMQ Artemis: Auth bypass for Core downstream federation (critical 9.3)
- [CVE-2026-49364](https://insights.sbomify.com/CVE-2026-49364/): Information disclosure in Apache ActiveMQ Artemis (critical 9.1)
- [CVE-2026-67593](https://insights.sbomify.com/CVE-2026-67593/): Missing authorization in Apache ActiveMQ Artemis (critical 9.1)
- [CVE-2023-50780](https://insights.sbomify.com/CVE-2023-50780/): Apache ActiveMQ Artemis: Authenticated users could perform RCE via Jolokia MBeans (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23913 and fix it if it is affected.

What it is: CVE-2022-23913 is a high-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 4 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23913 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:artemis-core-client (Maven): affected all versions; fixed in 2.19.1
- org.apache.activemq:artemis-core-client (Maven): affected all versions; fixed in 2.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23913/ (Markdown: https://insights.sbomify.com/CVE-2022-23913/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23913
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23913
- OSV: https://osv.dev/vulnerability/CVE-2022-23913

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23913/
Summaries are generated and may contain mistakes; the official description above is the record.
