{"answers":{"affected":"4 open source packages ship an affected version, including Weblate and weblate. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23915 in the wild and no public exploit code.","fix":"Upgrade Weblate to 4.11.1 or later.","what":"CVE-2022-23915 is a high-severity command injection vulnerability in Weblate, published on 4 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23915 and fix it if it is affected.\n\nWhat it is: CVE-2022-23915 is a high-severity command injection vulnerability in Weblate, published on 4 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23915 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- Weblate (PyPI): affected all versions; fixed in 4.11.1\n- Weblate (PyPI): affected all versions; fixed in 4.11.1\n- weblate (PyPI): affected all versions; fixed in 4.11.1\n- weblate (PyPI): affected all versions; fixed in 4.11.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23915/ (Markdown: https://insights.sbomify.com/CVE-2022-23915/index.md)","id":"CVE-2022-23915","markdown":"https://insights.sbomify.com/CVE-2022-23915/index.md","name":"CVE-2022-23915","record":{"aliases":["CVE-2022-24727","GHSA-3872-f48p-pxqj","GHSA-h2g5-2rhx-ffgj","SNYK-PYTHON-WEBLATE-2414088"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Weblate translation platform","requires_auth":"high_privilege","summary":"Authenticated users can achieve remote code execution via argument injection in git or mercurial repository operations.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"weblate","vendor":"weblate"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"The package weblate from 0 and before 4.11.1 are vulnerable to Remote Code Execution (RCE) via argument injection when using git or mercurial repositories. Authenticated users, can change the behavior of the application in an unintended way, leading to command execution.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote Code Execution (RCE)","id":"CVE-2022-23915","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":4,"n_references":4,"next":{"headline":"Cross-site scripting in a-blog cms","id":"CVE-2022-23916"},"packages":[{"ecosystem":"PyPI","fixed":["4.11.1"],"introduced":["0"],"last_affected":[],"package":"Weblate","purl":null,"source":"GHSA-3872-f48p-pxqj"},{"ecosystem":"PyPI","fixed":["4.11.1"],"introduced":["0"],"last_affected":[],"package":"Weblate","purl":null,"source":"GHSA-h2g5-2rhx-ffgj"},{"ecosystem":"PyPI","fixed":["4.11.1"],"introduced":["0"],"last_affected":[],"package":"weblate","purl":"pkg:pypi/weblate","source":"GHSA-3872-f48p-pxqj"},{"ecosystem":"PyPI","fixed":["4.11.1"],"introduced":["0"],"last_affected":[],"package":"weblate","purl":"pkg:pypi/weblate","source":"GHSA-h2g5-2rhx-ffgj"}],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority because it is Unused","id":"CVE-2022-23914"},"products":["Weblate"],"published":"2022-03-04","related":[{"cvss_score":9.1,"headline":"Weblate has git config file overwrite vulnerability that leads to remote code execution","id":"CVE-2025-68398","kev_date_added":null,"published":"2025-12-18"},{"cvss_score":8.8,"headline":"Weblate: Privilege escalation in the user API endpoint","id":"CVE-2026-34393","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":8.1,"headline":"Weblate: Remote code execution during backup restoration","id":"CVE-2026-33435","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":7.7,"headline":"Weblate: Arbitrary File Read via Symlink","id":"CVE-2026-34242","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":7.7,"headline":"Weblate has an arbitrary file read via symbolic links","id":"CVE-2025-68279","kev_date_added":null,"published":"2025-12-18"},{"cvss_score":6.8,"headline":"Weblate: JavaScript localization CDN add-on allows arbitrary local file read outside the repository","id":"CVE-2026-33220","kev_date_added":null,"published":"2026-04-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Authenticated users can achieve remote code execution via argument injection in git or mercurial repository operations.","url":"https://insights.sbomify.com/CVE-2022-23915/"}