# CVE-2022-23915: Remote Code Execution (RCE)

> Authenticated users can achieve remote code execution via argument injection in git or mercurial repository operations.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2022
- **Updated:** 17 Sep 2024
- **Also known as:** CVE-2022-24727, GHSA-3872-f48p-pxqj, GHSA-h2g5-2rhx-ffgj, SNYK-PYTHON-WEBLATE-2414088

## What is CVE-2022-23915?

CVE-2022-23915 is a high-severity command injection vulnerability in Weblate, published on 4 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The package weblate from 0 and before 4.11.1 are vulnerable to Remote Code Execution (RCE) via argument injection when using git or mercurial repositories. Authenticated users, can change the behavior of the application in an unintended way, leading to command execution.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2022-23915?

4 open source packages ship an affected version, including Weblate and weblate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Weblate` | PyPI | All versions | 4.11.1 |
| `Weblate` | PyPI | All versions | 4.11.1 |
| `weblate` | PyPI | All versions | 4.11.1 |
| `weblate` | PyPI | All versions | 4.11.1 |

Products: Weblate Weblate.

## How do I fix CVE-2022-23915?

Upgrade Weblate to 4.11.1 or later.

## Is CVE-2022-23915 being exploited?

There is no known exploitation of CVE-2022-23915 in the wild and no public exploit code.

## Other vulnerabilities in Weblate

- [CVE-2025-68398](https://insights.sbomify.com/CVE-2025-68398/): Weblate has git config file overwrite vulnerability that leads to remote code execution (critical 9.1)
- [CVE-2026-34393](https://insights.sbomify.com/CVE-2026-34393/): Weblate: Privilege escalation in the user API endpoint (high 8.8)
- [CVE-2026-33435](https://insights.sbomify.com/CVE-2026-33435/): Weblate: Remote code execution during backup restoration (high 8.1)
- [CVE-2026-34242](https://insights.sbomify.com/CVE-2026-34242/): Weblate: Arbitrary File Read via Symlink (high 7.7)
- [CVE-2025-68279](https://insights.sbomify.com/CVE-2025-68279/): Weblate has an arbitrary file read via symbolic links (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23915 and fix it if it is affected.

What it is: CVE-2022-23915 is a high-severity command injection vulnerability in Weblate, published on 4 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23915 in the wild and no public exploit code.

Affected packages and fixed versions:
- Weblate (PyPI): affected all versions; fixed in 4.11.1
- Weblate (PyPI): affected all versions; fixed in 4.11.1
- weblate (PyPI): affected all versions; fixed in 4.11.1
- weblate (PyPI): affected all versions; fixed in 4.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23915/ (Markdown: https://insights.sbomify.com/CVE-2022-23915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23915
- OSV: https://osv.dev/vulnerability/CVE-2022-23915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23915/
Summaries are generated and may contain mistakes; the official description above is the record.
