# CVE-2022-23944: Apache ShenYu 2.4.1 Improper access control

> Attackers can access plugin APIs without authentication, potentially reading or modifying configuration data in Apache ShenYu.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-6v39-p2xq-g5c3

## What is CVE-2022-23944?

CVE-2022-23944 is a critical missing authorization vulnerability in Apache ShenYu (incubating), published on 25 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

User can access /plugin api without authentication. This issue affected Apache ShenYu 2.4.0 and 2.4.1.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2022-23944?

2 open source packages ship an affected version, including org.apache.shenyu:shenyu-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.shenyu:shenyu-common` | Maven | From 2.4.0 | 2.4.2 |
| `org.apache.shenyu:shenyu-common` | Maven | From 2.4.0 | 2.4.2 |

Products: Apache Shenyu.

## How do I fix CVE-2022-23944?

Upgrade org.apache.shenyu:shenyu-common to 2.4.2 or later.

## Is CVE-2022-23944 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23944 exists.

Public exploit code:

- Apache ShenYu Admin Unauth Access (nuclei): http/cves/2022/CVE-2022-23944.yaml

## Other vulnerabilities in Apache ShenYu (incubating)

- [CVE-2021-45029](https://insights.sbomify.com/CVE-2021-45029/): Apache ShenYu 2.4.1 Groovy Code Injection & SpEL Injection (critical 9.8)
- [CVE-2021-37580](https://insights.sbomify.com/CVE-2021-37580/): Apache ShenYu Admin bypass JWT authentication (critical 9.8)
- [CVE-2022-42735](https://insights.sbomify.com/CVE-2022-42735/): Apache ShenYu Admin ultra vires (high 8.8)
- [CVE-2022-37435](https://insights.sbomify.com/CVE-2022-37435/): Apache ShenYu Admin Improper Privilege Management (high 8.8)
- [CVE-2022-26650](https://insights.sbomify.com/CVE-2022-26650/): Apache ShenYu (incubating) Regular expression denial of service (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23944 and fix it if it is affected.

What it is: CVE-2022-23944 is a critical missing authorization vulnerability in Apache ShenYu (incubating), published on 25 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23944 exists.

Affected packages and fixed versions:
- org.apache.shenyu:shenyu-common (Maven): affected from 2.4.0; fixed in 2.4.2
- org.apache.shenyu:shenyu-common (Maven): affected from 2.4.0; fixed in 2.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23944/ (Markdown: https://insights.sbomify.com/CVE-2022-23944/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23944
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23944
- OSV: https://osv.dev/vulnerability/CVE-2022-23944

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23944/
Summaries are generated and may contain mistakes; the official description above is the record.
