# CVE-2022-2400: External Control of File Name or Path in dompdf/dompdf

> An attacker can manipulate file paths to read or modify arbitrary files within the dompdf PHP library.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-2400, GHSA-5qj8-6xxj-hp9h, UBUNTU-CVE-2022-2400

## What is CVE-2022-2400?

CVE-2022-2400 is a medium-severity path traversal vulnerability in dompdf/dompdf, published on 18 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

External Control of File Name or Path in GitHub repository dompdf/dompdf prior to 2.0.0.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2022-2400?

2 open source packages ship an affected version, including dompdf/dompdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dompdf/dompdf` | Packagist | All versions | 2.0.0 |
| `dompdf/dompdf` | Packagist | All versions | 2.0.0 |

Products: Dompdf Project Dompdf.

## How do I fix CVE-2022-2400?

Upgrade dompdf/dompdf to 2.0.0 or later.

## Is CVE-2022-2400 being exploited?

There is no known exploitation of CVE-2022-2400 in the wild and no public exploit code.

## Other vulnerabilities in dompdf/dompdf

- [CVE-2023-24813](https://insights.sbomify.com/CVE-2023-24813/): URI validation failure on SVG parsing. Bypass of CVE-2023-23924 (critical 10.0)
- [CVE-2023-23924](https://insights.sbomify.com/CVE-2023-23924/): URI validation failure on SVG parsing in Dompdf (critical 10.0)
- [CVE-2021-3838](https://insights.sbomify.com/CVE-2021-3838/): PHAR Deserialization in dompdf/dompdf (critical 9.8)
- [CVE-2021-3902](https://insights.sbomify.com/CVE-2021-3902/): Improper Restriction of XML External Entity Reference in dompdf/dompdf (critical 9.8)
- [CVE-2022-28368](https://insights.sbomify.com/CVE-2022-28368/): Remote code injection in dompdf/dompdf (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2400 and fix it if it is affected.

What it is: CVE-2022-2400 is a medium-severity path traversal vulnerability in dompdf/dompdf, published on 18 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-2400 in the wild and no public exploit code.

Affected packages and fixed versions:
- dompdf/dompdf (Packagist): affected all versions; fixed in 2.0.0
- dompdf/dompdf (Packagist): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2400/ (Markdown: https://insights.sbomify.com/CVE-2022-2400/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2400
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2400
- OSV: https://osv.dev/vulnerability/CVE-2022-2400

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2400/
Summaries are generated and may contain mistakes; the official description above is the record.
