CVE-2022-2401 Team members could access sensitive information of other users via an API call
Team members can access sensitive information of other users via unrestricted API calls in Mattermost.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-2401?
CVE-2022-2401 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 14 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Unrestricted information disclosure of all users in Mattermost version 6.7.0 and earlier allows team members to access some sensitive information by directly accessing the APIs.
Weakness: CWE-200
Which versions are affected by CVE-2022-2401?
12 open source packages ship an affected version, including github.com/mattermost/mattermost-server/v6, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server/v6 Go | All versions | 6.3.9, 6.5.2, 6.6.2, 6.7.1 |
github.com/mattermost/mattermost-server/v6 Go | All versions | 6.3.9 |
github.com/mattermost/mattermost-server/v6 Go | All versions | 6.3.9 |
github.com/mattermost/mattermost-server/v6 Go | From 6.4.0 | 6.5.2 |
github.com/mattermost/mattermost-server/v6 Go | From 6.4.0 | 6.5.2 |
github.com/mattermost/mattermost-server/v6 Go | From 6.6.0 | 6.6.2 |
6 more packages
github.com/mattermost/mattermost-server/v6 Go | From 6.6.0 | 6.6.2 |
github.com/mattermost/mattermost-server/v6 Go | From 6.7.0 | 6.7.1 |
github.com/mattermost/mattermost-server/v6 Go | From 6.7.0 | 6.7.1 |
mattermost Bitnami | All versions to 6.6.0 | 6.3.9, 6.5.2 |
github.com/mattermost/mattermost-server Go | All versions | None |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2022-2401?
Upgrade github.com/mattermost/mattermost-server/v6 to a fixed version for your release line: 6.3.9, 6.5.2, 6.6.2 or 6.7.1.
Is CVE-2022-2401 being exploited?
There is no known exploitation of CVE-2022-2401 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2022-2401, GHSA-7ggc-5r84-xf54, GO-2022-0540.