{"answers":{"affected":"3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-24048 in the wild and no public exploit code.","fix":"Upgrade mariadb to a fixed version for your release line: 10.2.42, 10.3.33, 10.4.23 or 10.5.14.","what":"CVE-2022-24048 is a high-severity memory corruption vulnerability in Fedoraproject Fedora, published on 18 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24048 and fix it if it is affected.\n\nWhat it is: CVE-2022-24048 is a high-severity memory corruption vulnerability in Fedoraproject Fedora, published on 18 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24048 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mariadb (Bitnami): affected from 10.2.0; fixed in 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2, 10.8.1\n- mariadb-min (Bitnami): affected from 10.2.0 up to 10.8.0; fixed in 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2\n- mysql-client (Bitnami): affected from 10.2.0; fixed in 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2, 10.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24048/ (Markdown: https://insights.sbomify.com/CVE-2022-24048/index.md)","id":"CVE-2022-24048","markdown":"https://insights.sbomify.com/CVE-2022-24048/index.md","name":"CVE-2022-24048","record":{"aliases":["ALPINE-CVE-2022-24048","AZL-8664","BIT-mariadb-2022-24048","BIT-mariadb-min-2022-24048","BIT-mysql-client-2022-24048","DEBIAN-CVE-2022-24048","GHSA-3p23-jfm6-493m","UBUNTU-CVE-2022-24048"],"analysis":{"component_type":"database","fix_type":"patch","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"MariaDB database","requires_auth":"low_privilege","summary":"Local attackers with authentication can exploit a stack-based buffer overflow in MariaDB's CONNECT storage engine to execute arbitrary code and escalate privileges.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"zdi","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"mariadb","vendor":"mariadb"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-121","name":"Stack-based Buffer Overflow"}],"description":"MariaDB CONNECT Storage Engine Stack-based Buffer Overflow Privilege Escalation Vulnerability. This vulnerability allows local attackers to escalate privileges on affected installations of MariaDB. Authentication is required to exploit this vulnerability. The specific flaw exists within the processing of SQL queries. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of the service account. Was ZDI-CAN-16191.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in MariaDB","id":"CVE-2022-24048","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora","mariadb:mariadb"],"type":"memory_corruption","year":"2022"},"n_packages":3,"n_references":6,"next":{"headline":"Memory corruption in One Speaker","id":"CVE-2022-24049"},"packages":[{"ecosystem":"Bitnami","fixed":["10.2.42","10.3.33","10.4.23","10.5.14","10.6.6","10.7.2","10.8.1"],"introduced":["10.2.0","10.3.0","10.4.0","10.5.0","10.6.0","10.7.0","10.8.0"],"last_affected":[],"package":"mariadb","purl":"pkg:bitnami/mariadb","source":"BIT-mariadb-2022-24048"},{"ecosystem":"Bitnami","fixed":["10.2.42","10.3.33","10.4.23","10.5.14","10.6.6","10.7.2"],"introduced":["10.2.0","10.3.0","10.4.0","10.5.0","10.6.0","10.7.0","10.8.0"],"last_affected":["10.8.0"],"package":"mariadb-min","purl":"pkg:bitnami/mariadb-min","source":"BIT-mariadb-min-2022-24048"},{"ecosystem":"Bitnami","fixed":["10.2.42","10.3.33","10.4.23","10.5.14","10.6.6","10.7.2","10.8.1"],"introduced":["10.2.0","10.3.0","10.4.0","10.5.0","10.6.0","10.7.0","10.8.0"],"last_affected":[],"package":"mysql-client","purl":"pkg:bitnami/mysql-client","source":"BIT-mysql-client-2022-24048"}],"prev":{"headline":"Auth bypass in Track-It!","id":"CVE-2022-24047"},"products":["MariaDB"],"published":"2022-02-18","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["MariaDB"]},"summary":"Local attackers with authentication can exploit a stack-based buffer overflow in MariaDB's CONNECT storage engine to execute arbitrary code and escalate privileges.","url":"https://insights.sbomify.com/CVE-2022-24048/"}