# CVE-2022-24052: Memory corruption in MariaDB

> Local attackers with authentication can exploit a heap buffer overflow in MariaDB's CONNECT storage engine to execute arbitrary code and escalate privileges.

- **Severity:** High 7.0 (`CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2022-24052, AZL-8667, BIT-mariadb-2022-24052, BIT-mariadb-min-2022-24052, BIT-mysql-client-2022-24052, DEBIAN-CVE-2022-24052, GHSA-pfvf-3927-r9fx, OESA-2022-1619, UBUNTU-CVE-2022-24052

## What is CVE-2022-24052?

CVE-2022-24052 is a high-severity memory corruption vulnerability in Fedoraproject Fedora, published on 18 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

MariaDB CONNECT Storage Engine Heap-based Buffer Overflow Privilege Escalation Vulnerability. This vulnerability allows local attackers to escalate privileges on affected installations of MariaDB. Authentication is required to exploit this vulnerability. The specific flaw exists within the processing of SQL queries. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length heap-based buffer. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of the service account. Was ZDI-CAN-16190.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2022-24052?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | From 10.2.0 | 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2, 10.8.1 |
| `mariadb-min` | Bitnami | From 10.2.0 to 10.8.0 | 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2 |
| `mysql-client` | Bitnami | From 10.2.0 | 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2, 10.8.1 |

Products: Fedoraproject Fedora, Mariadb Mariadb.

## How do I fix CVE-2022-24052?

Upgrade mariadb to a fixed version for your release line: 10.2.42, 10.3.33, 10.4.23 or 10.5.14.

## Is CVE-2022-24052 being exploited?

There is no known exploitation of CVE-2022-24052 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24052 and fix it if it is affected.

What it is: CVE-2022-24052 is a high-severity memory corruption vulnerability in Fedoraproject Fedora, published on 18 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24052 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected from 10.2.0; fixed in 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2, 10.8.1
- mariadb-min (Bitnami): affected from 10.2.0 up to 10.8.0; fixed in 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2
- mysql-client (Bitnami): affected from 10.2.0; fixed in 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2, 10.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24052/ (Markdown: https://insights.sbomify.com/CVE-2022-24052/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24052
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24052
- OSV: https://osv.dev/vulnerability/CVE-2022-24052

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24052/
Summaries are generated and may contain mistakes; the official description above is the record.
