{"answers":{"affected":"3 open source packages ship an affected version, including cookiecutter. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-24065 in the wild and no public exploit code.","fix":"Upgrade cookiecutter to 2.1.1 or later.","what":"CVE-2022-24065 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 3 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24065 and fix it if it is affected.\n\nWhat it is: CVE-2022-24065 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 3 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24065 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cookiecutter (PyPI): affected all versions; fixed in 2.1.1\n- cookiecutter (PyPI): affected all versions; fixed in 2.1.1\n- cookiecutter (PyPI): affected all versions; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24065/ (Markdown: https://insights.sbomify.com/CVE-2022-24065/index.md)","id":"CVE-2022-24065","markdown":"https://insights.sbomify.com/CVE-2022-24065/index.md","name":"CVE-2022-24065","record":{"aliases":["DEBIAN-CVE-2022-24065","GHSA-f4q6-9qm4-h8j4","MGASA-2022-0258","PYSEC-2022-204","SNYK-PYTHON-COOKIECUTTER-2414281","UBUNTU-CVE-2022-24065"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python cookiecutter library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via argument injection in the cookiecutter library when using the checkout parameter.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"cookiecutter","vendor":"cookiecutter_project"},{"product":"fedora","vendor":"fedoraproject"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"The package cookiecutter before 2.1.1 are vulnerable to Command Injection via hg argument injection. When calling the cookiecutter function from Python code with the checkout parameter, it is passed to the hg checkout command in a way that additional flags can be set. The additional flags can be used to perform a command injection.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection","id":"CVE-2022-24065","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"command_injection","year":"2022"},"n_packages":3,"n_references":5,"next":{"headline":"Command Injection","id":"CVE-2022-24066"},"packages":[{"ecosystem":"PyPI","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"cookiecutter","purl":null,"source":"GHSA-f4q6-9qm4-h8j4"},{"ecosystem":"PyPI","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"cookiecutter","purl":"pkg:pypi/cookiecutter","source":"GHSA-f4q6-9qm4-h8j4"},{"ecosystem":"PyPI","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"cookiecutter","purl":"pkg:pypi/cookiecutter","source":"PYSEC-2022-204"}],"prev":{"headline":"Memory corruption in DICOM Viewer Pro","id":"CVE-2022-24064"},"products":["cookiecutter"],"published":"2022-06-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via argument injection in the cookiecutter library when using the checkout parameter.","url":"https://insights.sbomify.com/CVE-2022-24065/"}