# CVE-2022-24065: Command Injection

> Attackers can execute arbitrary commands via argument injection in the cookiecutter library when using the checkout parameter.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2022
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2022-24065, GHSA-f4q6-9qm4-h8j4, MGASA-2022-0258, PYSEC-2022-204, SNYK-PYTHON-COOKIECUTTER-2414281, UBUNTU-CVE-2022-24065

## What is CVE-2022-24065?

CVE-2022-24065 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 3 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package cookiecutter before 2.1.1 are vulnerable to Command Injection via hg argument injection. When calling the cookiecutter function from Python code with the checkout parameter, it is passed to the hg checkout command in a way that additional flags can be set. The additional flags can be used to perform a command injection.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-24065?

3 open source packages ship an affected version, including cookiecutter. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cookiecutter` | PyPI | All versions | 2.1.1 |
| `cookiecutter` | PyPI | All versions | 2.1.1 |
| `cookiecutter` | PyPI | All versions | 2.1.1 |

Products: Cookiecutter Project Cookiecutter, Fedoraproject Fedora.

## How do I fix CVE-2022-24065?

Upgrade cookiecutter to 2.1.1 or later.

## Is CVE-2022-24065 being exploited?

There is no known exploitation of CVE-2022-24065 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24065 and fix it if it is affected.

What it is: CVE-2022-24065 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 3 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24065 in the wild and no public exploit code.

Affected packages and fixed versions:
- cookiecutter (PyPI): affected all versions; fixed in 2.1.1
- cookiecutter (PyPI): affected all versions; fixed in 2.1.1
- cookiecutter (PyPI): affected all versions; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24065/ (Markdown: https://insights.sbomify.com/CVE-2022-24065/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24065
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24065
- OSV: https://osv.dev/vulnerability/CVE-2022-24065

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24065/
Summaries are generated and may contain mistakes; the official description above is the record.
