# CVE-2022-24066: Command Injection

> Attackers can execute arbitrary commands via git clone arguments in the simple-git library due to incomplete input validation.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-28xr-mwxg-3qc8

## What is CVE-2022-24066?

CVE-2022-24066 is a high-severity command injection vulnerability in simple-git, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package simple-git before 3.5.0 are vulnerable to Command Injection due to an incomplete fix of [CVE-2022-24433](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-2421199) which only patches against the git fetch attack vector. A similar use of the --upload-pack feature of git is also supported for git clone, which the prior fix didn't cover.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2022-24066?

2 open source packages ship an affected version, including simple-git. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simple-git` | npm | All versions | 3.5.0 |
| `simple-git` | npm | All versions | 3.5.0 |

Products: Simple-Git Project Simple-Git.

## How do I fix CVE-2022-24066?

Upgrade simple-git to 3.5.0 or later.

## Is CVE-2022-24066 being exploited?

There is no known exploitation of CVE-2022-24066 in the wild and no public exploit code.

## Other vulnerabilities in simple-git

- [CVE-2026-28292](https://insights.sbomify.com/CVE-2026-28292/): simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE (critical 9.8)
- [CVE-2026-102828](https://insights.sbomify.com/CVE-2026-102828/): simple-git unsafe-operation guard does not block trailer command configuration (critical 9.2)
- [CVE-2026-6951](https://insights.sbomify.com/CVE-2026-6951/): simple-git is vulnerable to Remote Code Execution (critical 9.2)
- [CVE-2026-102826](https://insights.sbomify.com/CVE-2026-102826/): simple-git allows command execution through unblocked Git configuration includes (high 8.1)
- [CVE-2026-102827](https://insights.sbomify.com/CVE-2026-102827/): simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -> command execution (residual of CVE-2026-28291) (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24066 and fix it if it is affected.

What it is: CVE-2022-24066 is a high-severity command injection vulnerability in simple-git, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-24066 in the wild and no public exploit code.

Affected packages and fixed versions:
- simple-git (npm): affected all versions; fixed in 3.5.0
- simple-git (npm): affected all versions; fixed in 3.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24066/ (Markdown: https://insights.sbomify.com/CVE-2022-24066/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24066
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24066
- OSV: https://osv.dev/vulnerability/CVE-2022-24066

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24066/
Summaries are generated and may contain mistakes; the official description above is the record.
