# CVE-2022-24086: Adobe Commerce and Magento Open Source Improper Input Validation

> Attackers can achieve arbitrary code execution via improper input validation in the checkout process without user interaction.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 15 Feb 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2022
- **Updated:** 21 Oct 2025
- **Also known as:** BIT-magento-2022-24086, GHSA-f8fv-f786-9933

## What is CVE-2022-24086?

CVE-2022-24086 is a critical code injection vulnerability in Adobe Commerce, published on 16 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability during the checkout process. Exploitation of this issue does not require user interaction and could result in arbitrary code execution.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-24086?

5 open source packages ship an affected version, including magento/community-edition and magento. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | From 2.3.3-p1 | 2.3.7-p3 |
| `magento/community-edition` | Packagist | From 2.3.3-p1 | 2.3.7-p3 |
| `magento/community-edition` | Packagist | From 2.4.0 | 2.4.3-p2 |
| `magento/community-edition` | Packagist | From 2.4.0 | 2.4.3-p2 |
| `magento` | Bitnami | All versions to 2.3.6 | 2.3.0 |

Products: Adobe Commerce, Adobe Magento.

## How do I fix CVE-2022-24086?

Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p3 or 2.4.3-p2. US federal agencies must fix it by 1 Mar 2022.

## Is CVE-2022-24086 being exploited?

Yes. Attackers have exploited CVE-2022-24086 in the wild since at least 15 Feb 2022.

Public exploit code:

- CVE-2022-24086 about Magento RCE  (github_poc): https://github.com/Mr-xn/CVE-2022-24086
- Verifed Proof of Concept on CVE-2022-24086 (github_poc): https://github.com/oK0mo/CVE-2022-24086-RCE-PoC
- Proof of concept of CVE-2022-24086 (github_poc): https://github.com/pescepilota/CVE-2022-24086
- https://github.com/seymanurmutlu/CVE-2022-24086-CVE-2022-24087 (github_poc): https://github.com/seymanurmutlu/CVE-2022-24086-CVE-2022-24087
- PoC of CVE-2022-24086 (github_poc): https://github.com/akr3ch/CVE-2022-24086
- CVE-2022-24086  RCE (github_poc): https://github.com/nanaao/CVE-2022-24086-RCE

## Other vulnerabilities in Adobe Commerce

- [CVE-2026-75650](https://insights.sbomify.com/CVE-2026-75650/): Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine (critical 10.0, exploited in the wild)
- [CVE-2024-34102](https://insights.sbomify.com/CVE-2024-34102/): Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE) (critical 9.8, exploited in the wild)
- [CVE-2026-48356](https://insights.sbomify.com/CVE-2026-48356/): Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type (critical 9.3, exploited in the wild)
- [CVE-2026-71362](https://insights.sbomify.com/CVE-2026-71362/): Adobe Commerce and Magento Incorrect Authorization Vulnerability (critical 9.1, exploited in the wild)
- [CVE-2025-54236](https://insights.sbomify.com/CVE-2025-54236/): Adobe Commerce and Magento Improper Input Validation (critical 9.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24086 and fix it if it is affected.

What it is: CVE-2022-24086 is a critical code injection vulnerability in Adobe Commerce, published on 16 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2022-24086 in the wild since at least 15 Feb 2022.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected from 2.3.3-p1; fixed in 2.3.7-p3
- magento/community-edition (Packagist): affected from 2.3.3-p1; fixed in 2.3.7-p3
- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.3-p2
- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.3-p2
- magento (Bitnami): affected all versions up to 2.3.6; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24086/ (Markdown: https://insights.sbomify.com/CVE-2022-24086/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24086
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24086
- OSV: https://osv.dev/vulnerability/CVE-2022-24086

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24086/
Summaries are generated and may contain mistakes; the official description above is the record.
