# CVE-2022-24112: Apache APISIX Authentication Bypass

> Attackers can bypass IP restrictions on the Admin API via the batch-requests plugin, potentially leading to remote code execution in default configurations.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 25 Aug 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Feb 2022
- **Updated:** 21 Oct 2025
- **Also known as:** BIT-apisix-2022-24112, GHSA-2vc7-6w39-6rh2

## What is CVE-2022-24112?

CVE-2022-24112 is a critical authentication bypass vulnerability in Apache APISIX, published on 11 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2022-24112?

1 open source package ship an affected version, including apisix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | All versions | 2.10.4, 2.12.1 |

Products: Apache Apisix.

## How do I fix CVE-2022-24112?

Upgrade apisix to a fixed version for your release line: 2.10.4 or 2.12.1. US federal agencies must fix it by 15 Sep 2022.

## Is CVE-2022-24112 being exploited?

Yes. Attackers have exploited CVE-2022-24112 in the wild since at least 25 Aug 2022.

Public exploit code:

- CVE-2022-24112：Apache APISIX apisix/batch-requests RCE (github_poc): https://github.com/Mr-xn/CVE-2022-24112
- Apache APISIX Remote Code Execution (CVE-2022-24112) proof of concept exploit  (github_poc): https://github.com/M4xSec/Apache-APISIX-CVE-2022-24112
- Apache APISIX < 2.12.1 Remote Code Execution and Docker Lab (github_poc): https://github.com/twseptian/cve-2022-24112
- Apache APISIX batch-requests RCE(CVE-2022-24112) (github_poc): https://github.com/SecNN/CVE-2022-24112
- CVE-2022-24112: Apache APISIX Remote Code Execution Vulnerability (github_poc): https://github.com/Mah1ndra/CVE-2022-24112
- CVE-2022-24112_POC (github_poc): https://github.com/Acczdy/CVE-2022-24112_POC

## Other vulnerabilities in Apache APISIX

- [CVE-2022-25757](https://insights.sbomify.com/CVE-2022-25757/): Apache APISIX: the body_schema check in request-validation plugin can be bypassed (critical 9.8)
- [CVE-2026-31908](https://insights.sbomify.com/CVE-2026-31908/): Apache APISIX: forward auth plugin allows header injection (critical 9.1)
- [CVE-2026-75005](https://insights.sbomify.com/CVE-2026-75005/): Apache APISIX: Unauthenticated CPU-exhaustion DoS (high 8.7)
- [CVE-2025-27446](https://insights.sbomify.com/CVE-2025-27446/): Privilege escalation in Apache APISIX Java Plugin Runner (high 7.8)
- [CVE-2026-31923](https://insights.sbomify.com/CVE-2026-31923/): Apache APISIX: Openid-connect `tls_verify` field is disabled by default (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-24112 and fix it if it is affected.

What it is: CVE-2022-24112 is a critical authentication bypass vulnerability in Apache APISIX, published on 11 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2022-24112 in the wild since at least 25 Aug 2022.

Affected packages and fixed versions:
- apisix (Bitnami): affected all versions; fixed in 2.10.4, 2.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-24112/ (Markdown: https://insights.sbomify.com/CVE-2022-24112/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-24112
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-24112
- OSV: https://osv.dev/vulnerability/CVE-2022-24112

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-24112/
Summaries are generated and may contain mistakes; the official description above is the record.
