{"answers":{"affected":"1 open source package ship an affected version, including mongodb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-24272 in the wild and no public exploit code.","fix":"Upgrade mongodb to 5.0.7 or later.","what":"CVE-2022-24272 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 21 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-24272 and fix it if it is affected.\n\nWhat it is: CVE-2022-24272 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 21 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-24272 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mongodb (Bitnami): affected from 5.0.0; fixed in 5.0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-24272/ (Markdown: https://insights.sbomify.com/CVE-2022-24272/index.md)","id":"CVE-2022-24272","markdown":"https://insights.sbomify.com/CVE-2022-24272/index.md","name":"CVE-2022-24272","record":{"aliases":["BIT-mongodb-2022-24272","GHSA-pg6q-x7mh-7cg2"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"MongoDB Server","requires_auth":"low_privilege","summary":"An authenticated user can crash the MongoDB server by triggering an assertion error via invalid commands to the external database.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mongodb","cpe":[{"product":"mongodb","vendor":"mongodb"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-617","name":"Reachable Assertion"}],"description":"An authenticated user may trigger an invariant assertion during command dispatch due to incorrect validation on the $external database. This may result in mongod denial of service or server crash. This issue affects: MongoDB Inc. MongoDB Server v5.0 versions, prior to and including v5.0.6.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MongoDB Server (mongod) may crash in response to unexpected requests","id":"CVE-2022-24272","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mongodb:mongodb","products":["mongodb:mongodb"],"type":"denial_of_service","year":"2022"},"n_packages":1,"n_references":1,"next":{"headline":"Directory Traversal","id":"CVE-2022-24278"},"packages":[{"ecosystem":"Bitnami","fixed":["5.0.7"],"introduced":["5.0.0"],"last_affected":[],"package":"mongodb","purl":"pkg:bitnami/mongodb","source":"BIT-mongodb-2022-24272"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2022-24266"},"products":["MongoDB Server"],"published":"2022-04-21","related":[{"cvss_score":8.7,"headline":"MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency","id":"CVE-2025-14847","kev_date_added":"2025-12-29","published":"2025-12-19"},{"cvss_score":9.2,"headline":"Auth bypass in MongoDB Server","id":"CVE-2026-82067","kev_date_added":null,"published":"2026-09-08"},{"cvss_score":9.2,"headline":"MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption","id":"CVE-2026-13072","kev_date_added":null,"published":"2026-07-22"},{"cvss_score":9.1,"headline":"Denial of service in n/a","id":"CVE-2017-15535","kev_date_added":null,"published":"2017-11-01"},{"cvss_score":9,"headline":"Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure","id":"CVE-2026-18691","kev_date_added":null,"published":"2026-08-11"},{"cvss_score":8.8,"headline":"MongoDB Server may allow successful untrusted connection","id":"CVE-2024-1351","kev_date_added":null,"published":"2024-03-07"},{"cvss_score":8.7,"headline":"Denial of service in MongoDB Server","id":"CVE-2026-82064","kev_date_added":null,"published":"2026-09-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["MongoDB Inc."]},"summary":"An authenticated user can crash the MongoDB server by triggering an assertion error via invalid commands to the external database.","url":"https://insights.sbomify.com/CVE-2022-24272/"}