CVE-2022-2428 Server-side request forgery in GitLab
An attacker can issue arbitrary HTTP requests via a crafted tag in the Jupyter Notebook viewer, potentially accessing internal resources.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-2428?
CVE-2022-2428 is a medium-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 17 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A crafted tag in the Jupyter Notebook viewer in GitLab EE/CE affecting all versions before 15.1.6, 15.2 to 15.2.4, and 15.3 to 15.3.2 allows an attacker to issue arbitrary HTTP requests
Weakness: CWE-79
Which versions are affected by CVE-2022-2428?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.0.0 | 15.1.6, 15.2.4, 15.3.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-2428?
Upgrade gitlab to a fixed version for your release line: 15.1.6, 15.2.4 or 15.3.2.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2022-2428 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2428 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-2428, GHSA-xcw3-xf4g-cwjj, UBUNTU-CVE-2022-2428.