CVE-2022-24280 Apache Pulsar Proxy target broker address isn't validated
An attacker with a valid token can force the Pulsar Proxy to initiate TCP connections to arbitrary addresses, enabling Denial of Service attacks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-24280?
CVE-2022-24280 is a medium-severity server-side request forgery vulnerability in Apache Pulsar, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Input Validation vulnerability in Proxy component of Apache Pulsar allows an attacker to make TCP/IP connection attempts that originate from the Pulsar Proxy's IP address. When the Apache Pulsar Proxy component is used, it is possible to attempt to open TCP/IP connections to any IP address and port that the Pulsar Proxy can connect to. An attacker could use this as a way for DoS attacks that originate from the Pulsar Proxy's IP address. It hasn’t been detected that the Pulsar Proxy authentication can be bypassed. The attacker will have to have a valid token to a properly secured Pulsar Proxy. This issue affects Apache Pulsar Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.2; 2.9.0 to 2.9.1; 2.6.4 and earlier.
Weakness: CWE-20
Which versions are affected by CVE-2022-24280?
6 open source packages ship an affected version, including org.apache.pulsar:pulsar. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.pulsar:pulsar Maven | All versions | 2.7.5 |
org.apache.pulsar:pulsar Maven | All versions | 2.7.5 |
org.apache.pulsar:pulsar Maven | From 2.8.0 | 2.8.3 |
org.apache.pulsar:pulsar Maven | From 2.8.0 | 2.8.3 |
org.apache.pulsar:pulsar Maven | From 2.9.0 | 2.9.2 |
org.apache.pulsar:pulsar Maven | From 2.9.0 | 2.9.2 |
Products include Apache Pulsar.
How do I fix CVE-2022-24280?
Upgrade org.apache.pulsar:pulsar to a fixed version for your release line: 2.7.5, 2.8.3 or 2.9.2.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2022-24280 being exploited?
There is no known exploitation of CVE-2022-24280 in the wild and no public exploit code.
Other vulnerabilities in Apache Pulsar
- CVE-2021-22160 Authentication with JWT allows use of “none”-algorithm
- CVE-2023-30429 Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy
- CVE-2024-27135 Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution
- CVE-2024-27894 Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying
- CVE-2024-27317 Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification
Sources
Also known as GHSA-3mg9-m3f6-v7fq.